0

enter image description here

The DHCP packet makes it from the Security computer all the way to the DHCP server and back to Router1 but gets stuck there. All all packets make it across when the device has a static ip assigned.

Text

Router1

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.3
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 129.137.107.130 255.255.255.128
 ip nat outside
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router eigrp 1
 network 129.137.107.128 0.0.0.127
 network 192.168.10.0
 network 192.168.20.0
 network 192.168.30.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Router0

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 2
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.2
 no ip address
 shutdown
!
interface FastEthernet0/0.3
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.5
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.6
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.7
 encapsulation dot1Q 60
 ip address 192.168.60.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.8
 encapsulation dot1Q 70
 ip address 192.168.70.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet1/0
 ip address 192.168.80.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 129.137.107.129 255.255.255.128
 ip nat outside
 clock rate 2000000
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router eigrp 1
 network 129.137.107.128 0.0.0.127
 network 192.168.2.0
 network 192.168.20.0
 network 192.168.40.0
 network 192.168.50.0
 network 192.168.60.0
 network 192.168.70.0
 network 192.168.80.0
 auto-summary
!
ip nat inside source list 10 interface Serial2/0 overload
ip nat inside source static tcp 192.168.80.3 80 129.137.107.131 80 
ip classless
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
6
  • Are you sure the dhcp scope matches the interface? – Ron Trunk Apr 21 at 21:45
  • The DHCP pools work if I try to do them without sending them across the 129.137.107.X network. – Christian Apr 22 at 1:36
  • What is the dhcp scope? – Ron Trunk Apr 22 at 2:01
  • The default gateway of 192.168.30.1 has starting IP address of 192.168.30.2 with 255.255.255.0 subnet mask. – Christian Apr 22 at 2:09
  • Try removing the nat statements – Ron Trunk Apr 22 at 3:15
1

Removed all the left over NAT commands from Router 1 and removed the inside command from fa1/0 and now DHCP is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.