0

enter image description here

Hi, I have this tipology, and I want configure the VOIP of host 192.168.0.6 So, first. This network has VTP and two vlans:

  • vlan 10 HOSTS
  • vlan 150 VOIP

in the switches the uplink is mode trunk allowed vlan 10 and 150.

Between the router and switches there is etherchannel configurated. Witch two port-channels.

Also the router has un server DHCP with name VOZ with the network 192.168.150.0

Here is the configurations:

R1:

Building configuration...

Current configuration : 1123 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool VOZ
network 192.168.150.0 255.255.255.0
default-router 192.168.150.1
option 150 ip 192.168.150.1
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Port-channel 1
 ip address 192.168.0.1 255.255.255.0
!
interface Port-channel 2
 ip address 192.168.150.1 255.255.255.0
!
interface FastEthernet0/0
 channel-group 1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1
 channel-group 1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1/0
 channel-group 2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1/1
 channel-group 2
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 192.168.150.1 port 2000
 auto assign 1 to 1
!
ephone-dn 1
 number 192168061
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

SW1:

Building configuration...

Current configuration : 2641 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,150
 channel-protocol lacp
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,150
 channel-protocol lacp
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/5
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/6
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/14
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/15
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/16
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/19
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/20
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/21
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/23
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/24
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Port-channel 1
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

RW2

Building configuration...

Current configuration : 2645 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,150
 channel-group 2 mode on
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,150
 channel-group 2 mode on
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/5
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/6
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/14
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/15
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/16
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/19
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/20
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/21
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/23
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/24
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Port-channel 2
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-R4

Building configuration...

Current configuration : 1267 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

SW5

Building configuration...

Current configuration : 1246 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport voice vlan 150
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

SW6

Building configuration...

Current configuration : 1226 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport trunk allowed vlan 10,150
 switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

The problems is in the telephone VOIP, this not get a ip address and the number. Why, if I the configure so this is not correct? file download .pkt: https://drive.google.com/file/d/1pOU5l8zUy_f7pmyP2f7oid7oeGGgolQu/view?usp=sharing

3
  • 1
    Switch interfaces to access devices (PCs, printers, phones, etc.) should be configured as access interfaces, not trunks. Normally, you put the interface into a PC access VLAN and use the switchport voice vlan <voice vlan> interface command to let a phone negotiate a trunk when the phone is connected to the interface.
    – Ron Maupin
    Apr 29 at 12:25
  • I in the SW5 in the interface fa0/6 has configured switchport access vlan 10 and switchport voice vlan 150
    – cleanet
    Apr 29 at 12:52
  • This is correct?
    – cleanet
    Apr 29 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.