0

enter image description here

R0 and R1 are linked with ospf , and R1 with static route with MLSw.
If i change R1 conn with MlSw to #ip route 0.0.0.0 0.0.0.0 g0/1 or g0/2 
i can ping , but need help with static route conf 

Current configuration : 1599 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 192.168.44.1 192.168.44.5
ip dhcp excluded-address 192.168.45.1 192.168.45.5
!
ip dhcp pool Vl44
 network 192.168.44.0 255.255.255.0
 default-router 192.168.44.1
 dns-server 8.8.8.8
ip dhcp pool Vl45
 network 192.168.45.0 255.255.255.0
 default-router 192.168.45.1
 dns-server 8.8.8.8
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524S4HU-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.44
 encapsulation dot1Q 44
 ip address 192.168.44.1 255.255.255.0
!
interface GigabitEthernet0/1.45
 encapsulation dot1Q 45
 ip address 192.168.45.1 255.255.255.0
!
interface Serial0/0/0
 ip address 192.168.200.1 255.255.255.252
 ip ospf network point-to-point
 ip ospf hello-interval 30
 ip ospf dead-interval 120
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 passive-interface GigabitEthernet0/1.44
 passive-interface GigabitEthernet0/1.45
 network 192.168.44.0 0.0.0.255 area 0
 network 192.168.45.0 0.0.0.255 area 0
 network 192.168.200.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

/////////////////////////////////////////////////////////////////////////////

   Router!#1version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15241LD1-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.150.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.101.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 192.168.200.2 255.255.255.252
 ip ospf network point-to-point
 ip ospf hello-interval 30
 ip ospf dead-interval 120
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 192.168.200.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 192.168.40.0 255.255.255.0 GigabitEthernet0/1 
ip route 192.168.30.0 255.255.255.0 GigabitEthernet0/1 
ip route 192.168.100.0 255.255.255.0 GigabitEthernet0/1 
ip route 192.168.50.0 255.255.255.0 GigabitEthernet0/0 
ip route 192.168.60.0 255.255.255.0 GigabitEthernet0/0 
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
7
  • Unfortunately, your question is too broad to answer as asked. Please edit the question to include the network device configurations. – Ron Maupin May 9 at 23:45
  • 1
    Please never use an image for text. Simply copy the text and paste it into the question using the Prefromatted-text feature ({}). – Ron Maupin May 9 at 23:49
  • im new i will get used to this platform , thnx for help – vus0707 May 9 at 23:50
  • We want to help, but we need you to edit the question with the text from all the network devices, much like this question. – Ron Maupin May 9 at 23:58
  • You keep putting in images for the configurations, but we need the text, not images. Look at the link in my last comment. Simply copy the text, paste it into the question, then highlight it and click the Preformatted-text feature button ({}) that is right next to the image feature button. – Ron Maupin May 10 at 0:13
0

You are getting the networks behind the first router on the second router via OSPF, so you do not need any static routes on the second router. You should remove those.

The first router needs to be told about the networks behind the second router, so you either need to include those in OSPF via network statements or redistributing connected routes on the second router, or you can put in two static routes on the first router for those two networks.

3
  • The second conf are for the first router , or router1 ..i dont know what to do more that lan 192.168.44.0 to ping to lan 192.168.50.0 for exmp ,,,but the conf of R1 have to remain Static route with MLSw., thnx for ur help – vus0707 May 10 at 0:48
  • OK, then reverse what I wrote. The second configuration does not need static routes because it is getting the routes via OSPF. It is the other router that does not know how to reach the networks in the second configuration. – Ron Maupin May 10 at 0:51
  • I appreciate your help – vus0707 May 10 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.