0

I have 4 ports.

3 are like this, Gi 0/1-3

switchport access vlan xxx
switchport mode access
power inline never
speed 100
spanning-tree portfast edge

One Trunk, Gi 0/8

switchport mode trunk
power inline never

Gi 0/2 keep disconnecting / reconnecting with tons of errors codes %LINEPROTO-5 UPDOWN and %LINK-3-UPDOWN if I remove the line speed 100

Why ?

4
  • 1
    What is in the log? Also, what is plugged into the port? Does it happen if you move devices around? – Ron Trunk May 17 at 16:44
  • These 2 lines are the only lines in the log. They keep coming if I used 1000 instead of 100. If I change port, the new port create the same error. Gi 0/1 is computer with VNC Server, Gi 0/1 and 0/2 are both VNC client – PowerCat May 18 at 15:22
  • Most likely, @Zac67 has the correct answer -- it's a cable problem – Ron Trunk May 18 at 16:30
  • 1
    On a side note (now that the actual problem is solved): If ever, on this and similar product families by Cisco, I suggest to use speed auto 100 10 instead of speed 100. It keeps speed & duplex negotiation intact while only offering 100 or 10 Mbits/sec. – Marc 'netztier' Luethi Jul 22 at 14:49
1

The speed 100 line configures the interface down to 100BASE-TX. If that works correctly and 1000BASE-T doesn't (the default, fully autonegotiated mode), the likely cause is a cable fault.

100BASE-TX and 10BASE-T use only two pairs of the four-pair cable. These pairs are also the ones used for autonegotiation. So, if one of the other pairs is at fault (or both), 1000BASE-T is still autonegotiated, but it can't complete the link due to the PCS sublayer failing to 'up' each lane/pair separately. This causes the port to fall back to autonegotiation, ad nauseam.

Some devices fall back to 100BASE-TX in such a case but that is not a given. Try a known-good cable.

2
  • We're going to change all the cable, I will make a feedback once it's done. Thank you ! – PowerCat May 19 at 11:57
  • And you were right. The cable were dead ! – PowerCat Jul 22 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.