1

I'm setting up a network on GNS3 with the end goal of configuring VxLAN. I routed 3 Arista vEOS router together and each of them has a host attached. With basic L3 routing, everything works. I need every host to be in VLAN 100. To do so, I moved the eth12's (directly connected to a host) IP address to VLAN 100's interface, put eth12 in switchport access mode, and made sure that everything was up and running. Here are the exact configs I used:

ip routing
!
vlan 100
name host
state active
!
int vlan 100
ip add 10.0.0.254/24
no shut
!
int eth12
switchport mode access
switchport access vlan 100
no shut
!

When I enter "show ip int brief", eth12 is up/up with no ip address assigned and VLAN 100 is down/lowerlayerdown. When I enter "show vlan", VLAN 100's only port is Cpu (no idea what that is). There is also no connectivity between host and router

This is my first time working on something like this and I followed Arista's documentation as best as I could. I'm sorry if this is a dumb question, but I couldn't find anything else out here.

7
  • Routers route traffic between networks, so every router interface is in a different network. Switches bridge frames on the same network. You use switches to connect devices on the same network, but routers to route between different networks.
    – Ron Maupin
    May 20 at 16:28
  • @RonMaupin I get that, but I'm trying to connect the 10.0.0.0/24 network to VLAN 100 so I can later configure VxLAN. What are my options then? Do I need to add an IP address to eth12 and forget about VLAN 100 or am I simply missing something?
    – BloodLord
    May 20 at 16:36
  • 1
    You really do not want to extend a VLAN across a WAN. That will greatly slow things and extend layer-2 problems at one site to other sites. We live in a layer-3 world, and there really is nothing anymore that requires devices to be on the same layer-2 LAN.
    – Ron Maupin
    May 20 at 16:43
  • 1
    I'm not asking whether you think I should or should not implement. I'm asking for help in troubleshooting the configuration.
    – BloodLord
    May 20 at 16:50
  • This configuration should work as expected. Please provide some more outputs, such as: show interface status, show interface eth12 switchport, show interface vlan 100, show vlan id 100, show spanning-tree May 28 at 8:34
1

Here's the answer if someone else stumbles upon this post. I initially routed every port to make sure GNS3 worked which required the "no switchport" command. Entering "switchport mode access" does not cancel out the previous command and the port will therefore still be routed. I had to enter "switchport" on eth12 interface for it to work. This may not be Arista specific per say, but I know that this interaction didn't occur while working on Cisco devices

1
  • After all, switchport mode access defines the VLAN mode for switching ports. ;-) Routing ports use subinterfaces. Please accept your own answer so this question doesn't keep popping up.
    – Zac67
    Jul 25 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.