3

On a Cisco 3750G switch I have a number (30-ish) of video processors in a vLAN providing multicast streams to clients via a router. Because all of the machines are in the same vLAN they see each other's output, this is causing issues because of the high volume of traffic.

Is there a way to isolate the multicast traffic so it isn't sent to all of the peer servers, and just the upstream (yet allow them to be in the same vLAN and see unicast traffic)? I was thinking that a private vLAN for each server/switch-port would do the trick. What would be the side-effects of this? Or can I use multicast blocking?

In the network diagram we have unicast video sources to each server on vLAN 1 (green). The encoders process the video and provide multicast streams (unique per encoder) to clients via vLAN 2 (red) and router 1. IGMP snooping is enabled on switch 2.

The problem is that the very high volume of traffic on the red vLAN is causing issues. A previous Network Engineer tried to resolve this at one location by splitting the red vLAN into multiple vLANs. This seemed to help, but didn't really solve the issue. I would like to know if we make all of the encoder ports in the red network into isolated ports in a private vLAN, so they don't see each other's traffic, would this solve this problem.

enter image description here

The switch config is:

# show running-config

version 12.2
[...]
!
hostname swtch02
!
[...]
system mtu routing 1500
ip routing
!
ip multicast-routing distributed
!
!
port-channel load-balance src-dst-ip
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
 name video_out
!
interface GigabitEthernet1/0/1
 description encoder-1
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 description encoder-2
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 description encoder-3
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 description encoder-4
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
[...]
!
interface Vlan2
 ip address 192.168.1.254 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
[...]
end
8
  • Something sounds wrong about the description above, but we need a lot more information to help; diagram (including individual video server multicast groups, ip addresses, switchport numbers, PIM RP - if any, etc), configuration of the switch, etc... please see this list of questions for more ideas about what to provide. Commented Apr 17, 2014 at 10:48
  • Mike, I think you are being too narrow in your review of this (and other) questions on this forum. This is a production, enterprise troubleshooting question which are specifically on-topic. I know you are doing this in a desire to keep this stack "clean" but you will kill off the critical mass. That being said, I will provide more details for my scenario as I really could use help finding a solution to this issue.
    – MERM
    Commented Apr 17, 2014 at 15:35
  • 1
    MERM, let's focus on the facts of your question instead of wild assumptions about other topics. If you have complaints about moderation, we would like to hear them - please voice your concerns in Network Engineering Meta, and cite specific examples. We are a group of volunteers who have jobs and real work to do; please respect our time by giving us enough information to help... admittedly that is a lot. However, it's not helpful for any of us to spend time writing answers when we don't have enough information to start. Commented Apr 17, 2014 at 15:39
  • Mike, I appreciate the time you volunteer. I was just commenting on what I perceived as an awful lot of questions being put on hold based on, an admittedly brief, review of questions. I will bring my concerns to Meta.
    – MERM
    Commented Apr 17, 2014 at 16:16
  • Mike, How do I get this question off hold so that it can be answered? What is the indication that the question was reviewed to take it off hold.
    – MERM
    Commented Apr 17, 2014 at 19:49

1 Answer 1

2

Are the sources using the same multicast address. If not make sure IGMP snooping is enabled on the switch. Private Vlans would prevent the servers from seeing each other even for unicast. If all the sources are using the same multicast address IGMP snooping would still work as long as the servers only transmit, but I am fuzzy.

3
  • IGMP snooping is enabled. Each source has its own multicast address.
    – MERM
    Commented Apr 17, 2014 at 4:27
  • 2
    If IGMP snooping is working right you should not be seeing traffic on a device unless it is sending an IGMP join. Have you tried the IGMP show commands on your switches to see if for some reason your encoders are sending IGMP joins?
    – fredpbaker
    Commented Apr 18, 2014 at 1:15
  • Fred, just another shot in the dark... we may want to check the dest mac-address of traffic from the encoders, in case something strange is happening... Commented Apr 18, 2014 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.