0

I have a Ruckus R310 that connected to Cisco 2960X and I saw a high RX pause frame.

show flowcontrol interface gi1/0/1
Port       Send FlowControl  Receive FlowControl  RxPause TxPause
           admin    oper     admin    oper
---------  -------- -------- -------- --------    ------- -------
Gi1/0/1    Unsupp.  Unsupp.  off       off         1513506148 0

GigabitEthernet1/0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0087.311e.bb81 (bia 0087.311e.bb81)
  Description: RuckusAP-R310
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 4/255, rxload 1/255

I tried to enable the flow control in the interface still the RX value keeps rising. I suspect this pause frame cause my internet to slow.

I want to know how to prevent this.

0

Flow control is already operating in your show output.

Since pause frames are received on that port, the source is the Ruckus WAP. As it seems, it cannot handle the data sent from the 2960X at full speed. That's not all too surprising as sustained gigabit speed on wireless isn't easily attained.

A WAP is essentially a network bridge - it can provide some buffering but when the ingress rates exceeds the egress rates for longer than buffer size divided by speed difference it can only drop frames. With flow control, it can signal the upstream switch and source(!) that it needs to slow down for a bit.

You could try without flow control but likely you won't see much of a difference (the dropped L2 payload is usually retransmitted at L4).

Most likely your wireless connection is the bottleneck. Simply try with a wired connection - if that's also slow it's probably your WAN link or the firewall.

2
  • that show command was taken after enabling flow control, then I clear counter. Thanks for recognizing it, I will edit it to off Jun 4 at 6:55
  • Anyway, the rest holds true. However, flow control reduces frame drops that would cause retransmissions from the source (possibly WAN), so I'd leave it enabled.
    – Zac67
    Jun 4 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.