0

I have a simple, linear topology in GNS3 that goes like this.

VPC1 > Switch > Router > VPC2

I have the default static IP Routes on the router set to 0.0.0.0 0.0.0.0 Ethernet0/1 and Ethernet1/0

I can ping from VPC1 to VPC2 without an issue. However, when I try to ping from the switch (Managed Cisco Switch) to PC2 I get a success rate of 0. I also can't ping the interface 1/0 of the router (which connects to VPC2). But I can successfully ping, from the switch, both PC1 and Router interface 0/0 (the one connected to the switch)

The IP on the switch is configured to its VLAN1 interface, which is in UP status.

So my questions are:

1/ Why can't I ping "past" the Ethernet0/0 interface of the router from the switch?

2/ Why is the ping directly from VPC1 to VPC2 successful whereas the one from the switch isn't? It's a linear topology, so shouldn't it be taking the same path?

Here is the Switch configuration.

hostname CiscoSwitch
!
boot-start-market
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 duplex auto
!
 interface Ethernet0/1
 duplex auto
!
interface Ethernet0/2
 duplex auto
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
 interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
interface Ethernet1/3
 duplex auto
!
interface Ethernet2/0
 duplex auto
!
 interface Ethernet2/1
 duplex auto
!
interface Ethernet2/2
 duplex auto
interface Ethernet2/3
 duplex auto
!
interface Ethernet3/0
 duplex auto
!
 interface Ethernet3/1
 duplex auto
!
interface Ethernet3/2
 duplex auto
interface Ethernet3/3
 duplex auto
!
interface Vlan1
 ip address 172.168.1.253 255.255.0.0
 !
 ip default-gateway 172.168.0.254
 !
 no ip http server
 !
 !
 !
 !
 control-plane
 !
 !
 line con 0
  exec-timeout 0 15
  privilege level 15
  logging synchronous
 line aux 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
 line vty 0 4
  login
 !
 end

router configuration

hostname R3600
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$iP0R$xM8wSmb7p7JOMCFVddGXe1
!
no aaa new-model
memory-size iomem 5
clock timezone GMT -6
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface Ethernet0/0
 description "Interfaz de Ethernet 0, conectada al Switch"
 ip address 172.168.0.254 255.255.0.0
 half-duplex
 ipv6 address 2001:CAFE:DEA:1::25/64
 ipv6 address FE80::1 link-local
!
interface Ethernet1/0
 description "Interfaz de Ethernet 1, conectada al equipo 2"
 ip address 172.169.0.254 255.255.0.0
 half-duplex
 ipv6 address 2001:CAFE:DEA::25/64
 ipv6 address FE80::1 link-local
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane

and vpc2

set pcname PC2
ip 172.169.0.252 172.169.0.254 16
ip 2001:cafe:dea::1/64

I am very new to this topic, so if there's some information I could provide, please let me know.

Thanks.

7
  • Unfortunately, you have not included your network device configurations, so we cannot answer your question. You can edit the question to include the configurations.
    – Ron Maupin
    Jun 7, 2021 at 19:54
  • I have added the configs
    – Dasph
    Jun 7, 2021 at 21:16
  • 1
    First, never set your ethernet interface duplex to half because you can really mess up with a duplex mismatch. Always leave the speed and duplex set to auto.
    – Ron Maupin
    Jun 7, 2021 at 21:23
  • That was a default configuration, I just changed it to auto though. But it doesn't seem to be related with the ability to ping VPC2
    – Dasph
    Jun 7, 2021 at 21:31
  • No, it is not related to that, but can cause problems. That should not be the default.
    – Ron Maupin
    Jun 7, 2021 at 21:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.