0

I have the following network Its an image before configuring the interfaces

With the following routing table:

enter image description here

Configuration of router 1

Building configuration...

Current configuration : 1056 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524KELG-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 189.135.190.142 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 189.135.190.146 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/3/0
 ip address 189.135.190.150 255.255.255.252
 clock rate 2000000
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 189.135.0.0
 network 189.135.190.140 0.0.0.3
 network 189.135.190.144 0.0.0.3
 network 189.135.190.148 0.0.0.3
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Configuration of router 2

Building configuration...

Current configuration : 1388 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15242TEU-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 189.135.190.154 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 189.135.190.158 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 189.135.190.162 255.255.255.252
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/0
 ip address 189.135.190.166 255.255.255.252
!
interface Serial0/3/1
 ip address 189.135.190.170 255.255.255.252
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 189.135.0.0
 network 189.135.190.152 0.0.0.3
 network 189.135.190.156 0.0.0.3
 network 189.135.190.160 0.0.0.3
 network 189.135.190.164 0.0.0.3
 network 189.135.190.168 0.0.0.3
 network 189.135.190.140 0.0.0.3
 network 189.135.190.144 0.0.0.3
 network 189.135.190.148 0.0.0.3
 network 189.135.190.0 0.0.0.3
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Configuration of router 3:

Current configuration : 954 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1524XOO5-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 189.135.190.174 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 189.135.190.178 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/3/0
 ip address 189.135.190.182 255.255.255.252
!
interface Serial0/3/1
 ip address 189.135.190.186 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 189.135.190.172 0.0.0.3
 network 189.135.190.176 0.0.0.3
 network 189.135.190.180 0.0.0.3
 network 189.135.190.184 0.0.0.3
 
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Configuration of router 4:

Building configuration...

Current configuration : 924 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524GKO1-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 189.135.190.190 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 189.135.190.194 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/3/0
 ip address 189.135.190.198 255.255.255.252
 clock rate 2000000
!
interface Serial0/3/1
 ip address 189.135.190.202 255.255.255.252
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

As you can see, I've already tried linking the networks together with the corresponding network ID but the legend saying "eigrp route linked" doesn't appear, so I'm doing something wrong. Any help is appreciated, thanks.

0

The router interfaces on both ends of the links must be in the same subnet. For example, the link between R1 and R2 is not addressed in the same subnet on each end.

7
  • so what should I do? change the interface of s0/2/0 in router 2 to 189.135.190.151? Jun 16 at 17:18
  • The network address is 189.135.190.148, so you would change R2 to 189.135.190.149. In other words, half of your address calculations are wrong.
    – Ron Trunk
    Jun 16 at 17:28
  • do you think it will suffice with my current network? or should I change something : example change the subnet mask so it allows more IPs in the same network. Jun 16 at 17:37
  • You definitely need to change at least half of your addresses. You can do so without changing the masks, but that's up to you.
    – Ron Trunk
    Jun 16 at 17:58
  • By the way, the interfaces connected to the PC switches are also wrong. For example, R3, Gi 0/0 has a /30 mask. That means only two usable addresses. But you have three hosts on that network: two PCs and the router interface.
    – Ron Trunk
    Jun 16 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.