0

I have the following network: enter image description here

The following is my interface table:

enter image description here

This is my PC IP address table:

enter image description here

This is the configuration for Router ISP:

ISP#show running-config
Building configuration...

Current configuration : 896 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15247AT0-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.26.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 209.165.200.225 255.255.255.224
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 172.16.26.0 0.0.0.7
 network 209.165.200.224 0.0.0.31
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Running configuration for Router 1:

Building configuration...

Current configuration : 1173 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524G2LA-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.27.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 209.165.200.226 255.255.255.224
!
interface Serial0/0/1
 ip address 172.16.28.1 255.255.255.0
!
interface Serial0/1/0
 ip address 192.168.26.1 255.255.255.252
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 172.16.27.0 0.0.0.255
 network 209.165.200.224 0.0.0.31
 network 172.16.28.0 0.0.0.255
 network 172.16.26.0 0.0.0.7
 network 192.168.26.0 0.0.0.7
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Running configuration for Router 2:

Building configuration...

Current configuration : 977 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX152490NS-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.27.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.26.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.28.1 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.27.0
 network 192.168.28.0
 network 192.168.26.0 0.0.0.7
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Running configuration for Router 3

Building configuration...

Current configuration : 983 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524IMGT-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.29.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.16.28.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.28.2 255.255.255.0
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.29.0
 network 172.16.28.0 0.0.0.255
 network 192.168.28.0
 auto-summary
 
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

I have successfully linked the network using EIGRP but yet when I try to send either a ping from one PC to another it doesn't go through. What could be wrong, or missing?

Show IP Route from router ISP:

ISP>show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C       172.16.26.0/30 is directly connected, GigabitEthernet0/0
L       172.16.26.1/32 is directly connected, GigabitEthernet0/0
D       172.16.27.0/24 [90/2170112] via 209.165.200.226, 00:44:21, Serial0/0/0
D       172.16.28.0/24 [90/2681856] via 209.165.200.226, 00:44:21, Serial0/0/0
     192.168.26.0/30 is subnetted, 1 subnets
D       192.168.26.0/30 [90/2681856] via 209.165.200.226, 00:44:21, Serial0/0/0
D    192.168.27.0/24 [90/2682112] via 209.165.200.226, 00:43:04, Serial0/0/0
D    192.168.28.0/24 [90/3193856] via 209.165.200.226, 00:44:21, Serial0/0/0
D    192.168.29.0/24 [90/2682112] via 209.165.200.226, 00:42:23, Serial0/0/0
     209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C       209.165.200.224/27 is directly connected, Serial0/0/0
L       209.165.200.225/32 is directly connected, Serial0/0/0

Show IP route from R1:

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
D       172.16.26.0/30 [90/2170112] via 209.165.200.225, 00:46:02, Serial0/0/0
C       172.16.27.0/24 is directly connected, GigabitEthernet0/0
L       172.16.27.1/32 is directly connected, GigabitEthernet0/0
C       172.16.28.0/24 is directly connected, Serial0/0/1
L       172.16.28.1/32 is directly connected, Serial0/0/1
     192.168.26.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.26.0/30 is directly connected, Serial0/1/0
L       192.168.26.1/32 is directly connected, Serial0/1/0
D    192.168.27.0/24 [90/2170112] via 192.168.26.2, 00:44:45, Serial0/1/0
D    192.168.28.0/24 [90/2681856] via 192.168.26.2, 00:44:45, Serial0/1/0
                     [90/2681856] via 172.16.28.2, 00:44:04, Serial0/0/1
D    192.168.29.0/24 [90/2170112] via 172.16.28.2, 00:44:04, Serial0/0/1
     209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C       209.165.200.224/27 is directly connected, Serial0/0/0
L       209.165.200.226/32 is directly connected, Serial0/0/0

Show IP route from R2:

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.26.0/30 [90/2682112] via 192.168.26.1, 00:49:26, Serial0/0/0
D       172.16.27.0/24 [90/2170112] via 192.168.26.1, 00:49:26, Serial0/0/0
D       172.16.28.0/24 [90/2681856] via 192.168.26.1, 00:49:26, Serial0/0/0
                       [90/2681856] via 192.168.28.2, 00:48:45, Serial0/0/1
     192.168.26.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.26.0/30 is directly connected, Serial0/0/0
L       192.168.26.2/32 is directly connected, Serial0/0/0
     192.168.27.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.27.0/24 is directly connected, GigabitEthernet0/0
L       192.168.27.1/32 is directly connected, GigabitEthernet0/0
     192.168.28.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.28.0/24 is directly connected, Serial0/0/1
L       192.168.28.1/32 is directly connected, Serial0/0/1
D    192.168.29.0/24 [90/2170112] via 192.168.28.2, 00:48:45, Serial0/0/1
     209.165.200.0/27 is subnetted, 1 subnets
D       209.165.200.224/27 [90/2681856] via 192.168.26.1, 00:49:26, Serial0/0/0

Show IP route from R3:

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.16.26.0/30 [90/2682112] via 172.16.28.1, 00:51:10, Serial0/0/0
D       172.16.27.0/24 [90/2170112] via 172.16.28.1, 00:51:10, Serial0/0/0
C       172.16.28.0/24 is directly connected, Serial0/0/0
L       172.16.28.2/32 is directly connected, Serial0/0/0
     192.168.26.0/30 is subnetted, 1 subnets
D       192.168.26.0/30 [90/2681856] via 192.168.28.1, 00:51:10, Serial0/0/1
                        [90/2681856] via 172.16.28.1, 00:51:10, Serial0/0/0
D    192.168.27.0/24 [90/2170112] via 192.168.28.1, 00:51:10, Serial0/0/1
     192.168.28.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.28.0/24 is directly connected, Serial0/0/1
L       192.168.28.2/32 is directly connected, Serial0/0/1
     192.168.29.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.29.0/24 is directly connected, GigabitEthernet0/0
L       192.168.29.1/32 is directly connected, GigabitEthernet0/0
     209.165.200.0/27 is subnetted, 1 subnets
D       209.165.200.224/27 [90/2681856] via 172.16.28.1, 00:51:10, Serial0/0/0
2
  • There could be thousand things. Configuration from switches is not shown - do they participate in the routing? One thing that's worth trying (shoot in the dark) is to disable the auto-summary within eigrp. (no auto-summary). That may do the trick, but there are many operational unknowns, such as routing table status, interface statuses, router-switch configuration, etc, etc. Provide more information from switches - show int status, show vlan, show ip int brief, show ip route, also from the PC standpoint - what is the configuration there - IP addresses (ipconfig) arp, etc Jun 17 at 9:22
  • @DanailPetrov No, the switches do not participate in the routing. They shouldn't interfere. I have already disabled auto-summary without success. I'll provide more configurations in a minute. Jun 17 at 14:20
0

You can troubleshoot problems like this in a deliberate, incremental manner:

  1. Are the default gateways on the PCs set correctly? They should be set to the router interface address.

  2. From each PC, can you ping the default gateway?

  3. Can you ping other interfaces on the router? for example, can PC0 ping the s0/0/0 interface on ISP router?

  4. Can you ping the next-hop router? Can PC0 ping any interface on R1?

You can proceed in a similar manner to the destination PC until you find the issue.

7
  • hello again! Yes, I can ping the default gateway. Yes I can ping till the first router that the PC encounters, but beyond that the request dies. And no, I can't ping anything outside the first router. I cant even ping the next network (from PC1, 209.165.200.225) Jun 17 at 14:33
  • Are you sure your default gateway is set correctly? Please edit your question to include the output on the first router from "show ip route."
    – Ron Trunk
    Jun 17 at 14:54
  • The tables look right, so I'm back to default gateway. what is it set to?
    – Ron Trunk
    Jun 17 at 15:14
  • Ready, I added the show IP route from all routers. the default gateway from PC1 is 172.16.26.0 Jun 17 at 15:15
  • When you mention the default gateway, you're talking about the one from a PC right? Jun 17 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.