I encounter the error message in the picture when attempting to access a Cisco ASA using ASDM in a test environment.

enter image description here


=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2021.07.03 11:01:46 =~=~=~=~=~=~=~=~=~=~=~=
show run
: Saved
ASA Version 8.2(5) 
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
interface Ethernet0/0
 switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
 nameif inside
 security-level 100
 ip address 
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute 
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-7161.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL 
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
dhcpd address inside
dhcpd enable inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username cisco password 3USUcOPFUiMCO4Jk encrypted
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
: end

ciscoasa# terminal pager 24



=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2021.07.03 11:07:17 =~=~=~=~=~=~=~=~=~=~=~=
show ver

Cisco Adaptive Security Appliance Software Version 8.2(5) 
Device Manager Version 7.16(1)

Compiled on Fri 20-May-11 16:00 by builders
System image file is "disk0:/asa825-k8.bin"
Config file at boot was "startup-config"

ciscoasa up 43 mins 53 secs

Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
Internal ATA Compact Flash, 128MB
BIOS Flash Firmware Hub @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-5505 on-board accelerator (revision 0x0)
                             Boot microcode   : CN1000-MC-BOOT-2.00 
                             SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
                             IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.05

 0: Int: Internal-Data0/0    : address is 30f7.0d7e.96c7, irq 11
 1: Ext: Ethernet0/0         : address is 30f7.0d7e.96bf, irq 255
 2: Ext: Ethernet0/1         : address is 30f7.0d7e.96c0, irq 255
 3: Ext: Ethernet0/2         : address is 30f7.0d7e.96c1, irq 255
 4: Ext: Ethernet0/3         : address is 30f7.0d7e.96c2, irq 255
 5: Ext: Ethernet0/4         : address is 30f7.0d7e.96c3, irq 255
 6: Ext: Ethernet0/5         : address is 30f7.0d7e.96c4, irq 255
 7: Ext: Ethernet0/6         : address is 30f7.0d7e.96c5, irq 255
 8: Ext: Ethernet0/7         : address is 30f7.0d7e.96c6, irq 255
 9: Int: Internal-Data0/1    : address is 0000.0003.0002, irq 255
10: Int: Not used            : irq 255
11: Int: Not used            : irq 255

Licensed features for this platform:
Maximum Physical Interfaces    : 8         
VLANs                          : 3, DMZ Restricted
Inside Hosts                   : Unlimited 
Failover                       : Disabled
VPN-DES                        : Enabled   
VPN-3DES-AES                   : Enabled   
SSL VPN Peers                  : 2         
Total VPN Peers                : 10        
Dual ISPs                      : Disabled  
VLAN Trunk Ports               : 0         
Shared License                 : Disabled
AnyConnect for Mobile          : Disabled  
AnyConnect for Cisco VPN Phone : Disabled  
AnyConnect Essentials          : Disabled  
Advanced Endpoint Assessment   : Disabled  
UC Phone Proxy Sessions        : 2         
Total UC Proxy Sessions        : 2         
Botnet Traffic Filter          : Disabled  

This platform has a Base license.

Serial Number: JMX163740JK
Running Activation Key: 0x0831e55c 0x148be91f 0x18d06998 0xb9b8ec30 0x8b2813a0 
Configuration register is 0x1
Configuration last modified by enable_15 at 00:14:12.269 UTC Thu Aug 28 2008

  • You need to assign VLAN 1 to some interface. Additionally, the ASA should use routed ports, no SVI.
    – Zac67
    Commented Jul 3, 2021 at 18:05
  • The (ancient) 5505 doesn't have any routed ports. It's all through an 8 port builtin switch. VLAN 1 is the default.
    – Ricky
    Commented Jul 3, 2021 at 21:32
  • 1
    Is the web server enabled on the ASA? (try accessing it directly via
    – Ricky
    Commented Jul 3, 2021 at 21:34
  • 1
    Did you generate an SSL certificate on the ASA? One is required for the HTTP(s) server and SSH. If you didn’t, that’s going to stop ASDM from working properly.
    – Jesse P.
    Commented Jul 4, 2021 at 18:03
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Nov 19, 2022 at 23:23

2 Answers 2


Here's how it's supposed to work. A fresh ASA 5505 will come with some default config on it (more config lines than if you were to "write erase" and reload it) that has, among other things, the following:

  1. An IP address on vlan 1
  2. The 8 ports in vlan 1
  3. A DHCP range to offer
  4. An ASDM image to use
  5. The HTTP server enabled
  6. A self-signed SSL certificate
  7. The crypto trustpoint assigned to the interface

From your config above, you have all of these except the last two. I think you could get this unit working with a couple steps.

  1. Console to the ASA using one of those blue Cisco console cables.
  2. Login to the console. Enter config mode. Add the commands:
crypto key gen rsa gen mod 1024
ssh inside
ssh ver 2
crypto ca trustpoint my-self-signed
 enrol term
crypto ca enroll my-self-signed
ssl trust-point my-self-signed inside

  1. Connect your computer to one of the last 7 ports on the ASA. (The first port is not in vlan 1)
  2. Try to open the ASDM again at

If you have tried all the reset already, that specific kind of error for me has always been solved by updating my Java install. Make sure you uninstall any old versions first and then install the latest Java version 8 release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.