1

I am trying to send multicast traffic from 3 Senders to corresponding Receivers in same VLAN (100) spread across 3 switches. 3 Switch and 3 Sender-Receiver I setup a Querier in one of the switch, but it doesn't seem to forward multicast traffic as expected.

Configs
AX-1:

interface tengigabitethernet 0/25
  switchport mode trunk
  switchport trunk allowed vlan 100
                                     
interface tengigabitethernet 0/27
  switchport mode access
  switchport access vlan 100

interface tengigabitethernet 0/28
  switchport mode access
  switchport access vlan 100

interface vlan 100
  ip igmp snooping

AX-2:

interface tengigabitethernet 0/25     
  switchport mode trunk               
  switchport trunk allowed vlan 100
                                 
interface tengigabitethernet 0/26     
  switchport mode trunk               
  switchport trunk allowed vlan 100
 
interface tengigabitethernet 0/27
  switchport mode access              
  switchport access vlan 100          

interface tengigabitethernet 0/28     
  switchport mode access              
  switchport access vlan 100          
                         
interface vlan 100                    
  ip address 192.168.100.20 255.255.255.0 
  ip igmp snooping                    
  ip igmp snooping querier

AX-3:

interface tengigabitethernet 0/25     
  switchport mode trunk               
  switchport trunk allowed vlan 100         
                               
interface tengigabitethernet 0/27     
  switchport mode access              
  switchport access vlan 100          
                                 
interface tengigabitethernet 0/28     
  switchport mode access              
  switchport access vlan 100          
         
interface vlan 100 
  ip igmp snooping

In AX-3, there is one IGMP group for Receiver-4.

VLAN 100   Group counts: 1
  Group Address     MAC Address         Version      Mode
  232.58.164.221    0100.xxxx.xxxx      V2           -
    Port-list:0/27

In AX-1, there are two IGMP groups for Receiver-1 and Receiver-5.

VLAN 100   Group counts: 2
  Group Address     MAC Address         Version      Mode
  225.97.166.93     0100.xxxx.xxxx      V2           -
    Port-list:0/27

  225.123.82.128    0100.xxxx.xxxx      V2           -
    Port-list:0/28

And nothing for AX-2.

Is my choice of Querier Switch incorrect or do i need to setup a mrouter instead?
Note: The switches are Alaxala(AX2500S Series) switches.

3
  • Please add the full (sanitized) configs to your question and use the { } function for proper formatting.
    – Zac67
    Aug 5 at 5:40
  • 2
    I think you misunderstand what a "querier" does. It just there to broadcast group membership report requests to keep information from expiring. It has nothing to do with actual forwarding.
    – Ricky
    Aug 5 at 10:49
  • @Ricky, Ok I understood what the Querier does. So, what might be causing the trunk ports to not forward the traffic?
    – codeCat
    Aug 5 at 13:44
2

There's nothing in the table on AX-2 because there are no consumers on AX-2, just transmitters. Thus, there's nothing to be pruned. Transmitters don't join the group into which they transmit, so they will not generate joins or list those groups in their membership report.

(If you were running multicast routing, then sources would be in the tables.)

1
  • If i check each port individually, i see the source address listed under "Last Reporter".
    – codeCat
    Aug 6 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.