0

So I have bought used ISR C897VA with an issue: when vlan1 is pinged from windows there are quite a lot of "Request timed out"s. Config-register 0x2142 has been done, as well as resetting startup-config. PC is just connected to gi5 and the router's configuration is:

int vlan
ip address 192.168.0.1 255.255.255.0

ping 192.168.0.1 -t

Pinging 192.168.0.1 with 32 bytes of data:
Reply from 192.168.0.1: bytes=32 time=1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time=2ms TTL=255
Reply from 192.168.0.1: bytes=32 time=3ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.1: bytes=32 time<1ms TTL=255
Request timed out.
Request timed out.

If I run on PC >arp -d 192.168.0.1. It removes 192.168.0.1 and MAC from windows's arp table and therefore forces it to do arp request. If PC is currently receiving ping replies from Vlan1, by doing arp -d 192.168.0.1 the PC will stop receving those replies and vice versa, as seen on this Wireshard screenshot:

enter image description here

Why is it happening? Is it hardware issue?

UPDATE

Connection diagram (except the router is C897VA):

enter image description here

Router#sh running-config
Building configuration...

Current configuration : 1667 bytes
!
! Last configuration change at 12:08:07 UTC Sun Aug 8 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C897VA-K9 sn FCZ22381163
!
!
!
redundancy
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
!
interface Ethernet0
 no ip address
 shutdown
!
interface GigabitEthernet0
 no ip address
!
interface GigabitEthernet1
 no ip address
!
interface GigabitEthernet2
 no ip address
!
interface GigabitEthernet3
 switchport mode access
 no ip address
!
interface GigabitEthernet4
 no ip address
!
interface GigabitEthernet5
 switchport mode access
 no ip address
!
interface GigabitEthernet6
 no ip address
!
interface GigabitEthernet7
 no ip address
!
interface GigabitEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ipv6 ioam timestamp
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
!
!
!
!
!
!
end
6
  • when vlan1 is pinged - does that mean the router's SVI? ARP response are timely, so the router may just been limiting its outgoing ICMP rate.
    – Zac67
    Aug 8 '21 at 10:46
  • @Zac67, I guess yes, it is by design on this model Cisco C897VA, Giga0-7 cannot be assigned to any ip
    – Qeeet
    Aug 8 '21 at 10:48
  • @Zac67, if it so, is it possible to remove the limit?
    – Qeeet
    Aug 8 '21 at 10:49
  • @Zac67, it definitely does not look like normal operation. When I had it set up to route to the internet, the youtube videos were loading very slowly and inversely with sync with "Request timed out"s. And speed test showed 3Mbit/s as opposed to 15mbit/s with cheap chineese router
    – Qeeet
    Aug 8 '21 at 10:52
  • You'll need to show us your network setup (diagram) and the (sanitized) router configuration.
    – Zac67
    Aug 8 '21 at 12:03
2

I notice two things:

  • On the router, GigabitEthernet5 where your end system is connected to does not have spanning-tree portfast (or spanning tree port type edge in some younger Cisco dialects).
  • (assuming that Windows still has that 4sec-something delay to report a "time out" in ping) there seems to be somewhat of a pattern of 6 timeouts, 1 success, 6 timeouts.

Could it be that Gi5 is flapping, because of a cabling or NIC defect, and right after line protocol up, spanning-tree's BLK/LIS/LRN prevents pretty much anything going int/out of that switchport?

QUESTIONS:

  • What do you get from show interface counters errors and show logging ?
  • What does the connected system's OS report about RX errors on the NIC (if such counters are accessible on the given OS)?
  • Did you try another cable and another port on the router's integrated switch?
  • Did you try the same with the router's Ethernet WAN Port? (GigabitEthernet8). It is a routed port and will take an "direct" configuration of IP and subnet mask. Also, not being a switchport, spanning-tree topics don't apply.
4
  • STP would block the port for ~30s. Wireshark is showing something odd going on with the host... arp, send two requests, arp again, and now everything works.
    – Ricky
    Aug 8 '21 at 22:11
  • @Ricky I agree that 6x4sec (as I assumed) would not add up to 30. Then again in the Wireshark excerpt, in the two examples where the host sends out two echo requests in sequence before arp'ing again, You can see that the echo requests are even 5 seconds apart. Aug 9 '21 at 5:02
  • It sends the ARP request and gets an answer immediately. STP IS NOT BLOCKING THE PORT.
    – Ricky
    Aug 9 '21 at 14:05
  • it is highly possible that the router is defective. Unfortunately, I don't have the time for now and the room space to setup the router again. But definitely will do so later. I accept your answer for now, and later will return here with comments/answers
    – Qeeet
    Dec 25 '21 at 16:07
2

Client's ARP requests affect whether Cisco C897VA receives packages or not

ping is not necessarily a meaningful instrument to determine if packets make it or not in general. ICMP generation is low-priority anyway and may additionally be limited by (default) configuration for DoS protection.

What you see is likely an artifact created by a) the router's ICMP outbound rate limiting and b) its ARP cache timeout.

Check out which ICMP rate limiting is currently active. The common Cisco syntax is show ip icmp rate-limit. You can change the (default) limiting by ip icmp rate-limit - generally, you should not deactivate it altogether but change the limit to your requirements.

5
  • ping is one packet per second, so rate-limit would not apply. The fact that windows is asking twice makes this a windows (host) issue.
    – Ricky
    Aug 8 '21 at 14:26
  • @Ricky Very possible - we don't really know enough about the scenario to be sure.
    – Zac67
    Aug 8 '21 at 16:22
  • @Ricky, it is tested with two different machines: one running Win10, another Win7. I'll test it with linux soon and report
    – Qeeet
    Aug 8 '21 at 16:50
  • @Zac67, you can see all the packets on Wireshark, except STP. Ignore !(ip.addr==192.168.0.2) as the screenshot was made with that PC unplugged. There seems nothing odd with setup to me. I ping cheap chinese ZTE router with no problems.
    – Qeeet
    Aug 8 '21 at 16:53
  • @Zac67, Reproducible on Raspberry pi 4, though hadn't installed wireshark, nor forced pi to send arp request.
    – Qeeet
    Aug 8 '21 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.