1

I have tried configuring a Ipv6 subnet address 2001:0dce:0000:0000::1/53 into the router interface.

It works but when the I tried setting the auto-configuration button on the PC connected to this interface, it does not work. However, if I put the Ipv6 address as 2001:0dce:0000:0000::1/64, it works instead. But for my project, it requires a /53 prefix length. How can I fix this?

3
  • You really only want to use /64 IPv6 networks as other sizes break some IPv6 features. See the answer to this question.
    – Ron Maupin
    Aug 14 at 14:30
  • "Break". I've used non-/64's for many, many years without any broken behavior. (I do so intentionally to stop SLAAC... android won't do anything but SLAAC.)
    – Ricky
    Aug 14 at 14:35
  • Also, the "64bit boundary" is antithetical to the foundation of IPv6: there are no classes, there is no line dividing "host" and "network". But since SLAAC drew that line, every other nut has hitched their horse to it.
    – Ricky
    Aug 14 at 14:45
3

SLAAC REQUIRES the prefix length be 64. If it is not, DHCPv6 (and static) is the only way hosts can get an address.

2
  • 1
    For the record, I've crusaded against this stupid, unnecessary limitation for a decade. Since almost everything supports privacy extensions and DAD, there's no reason to keep clinging to the infinitely bad idea of EUI-64 (MAC) derived automatic addresses.
    – Ricky
    Aug 14 at 14:32
  • 1
    I've been on the same side of that "crusade" for a while; my presentation sides on some of the problems with /64 LANs and mitigations (some of which have been implemented by Cisco, Juniper, and others in the years since): inconcepts.biz/~jsw/IPv6_NDP_Exhaustion.pdf Aug 14 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.