0

I need help. I don't know what i did wrong because i have configured the dhcp pool, subinterfaces and dhcp relay agent. Gateway pc uses static ip address while Branch pc acquired their ip address through dhcp server which is the Gateway router. The only problem now is the pc on the Branch side is not getting the ip address.

![enter image description here

--Gateway router--

ip dhcp excluded-address 192.168.1.0 192.168.1.5  
ip dhcp excluded-address 202.188.1.0 202.188.1.5  
ip dhcp excluded-address 172.16.1.0 172.16.1.5  
!  
ip dhcp pool ADMIN  
 network 192.168.1.0 255.255.255.0  
 default-router 192.168.1.1  
ip dhcp pool STAFF  
 network 202.188.1.0 255.255.255.0  
 default-router 202.188.1.1  
ip dhcp pool GUEST  
 network 172.16.1.0 255.255.255.0  
 default-router 172.16.1.1  
!  
!  
!  
no ip cef  
no ipv6 cef  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
spanning-tree mode pvst  
!  
!  
!  
!  
!  
!  
interface GigabitEthernet0/0/0  
 no ip address  
 duplex auto  
 speed auto  
!  
interface GigabitEthernet0/0/0.10  
 encapsulation dot1Q 10  
 ip address 192.168.1.1 255.255.255.0  
!  
interface GigabitEthernet0/0/0.20  
 encapsulation dot1Q 20  
 ip address 202.188.1.1 255.255.255.0  
!  
interface GigabitEthernet0/0/0.30  
 encapsulation dot1Q 30  
 ip address 172.16.1.1 255.255.255.0  
!  
interface GigabitEthernet0/0/1  
 no ip address  
 duplex auto  
 speed auto  
 shutdown  
!  
interface GigabitEthernet0/0/2  
 no ip address  
 duplex auto  
 speed auto  
 shutdown  
!  
interface Serial0/1/0  
 ip address 10.0.0.1 255.255.255.252  
 clock rate 128000  
!  
interface Serial0/1/1  
 no ip address  
 clock rate 2000000  
 shutdown  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
router ospf 1  
 router-id 1.1.1.1  
 log-adjacency-changes  
 network 10.0.0.0 0.0.0.3 area 0  
 network 192.168.1.0 0.0.0.255 area 0  
 network 202.188.1.0 0.0.0.255 area 0  
 network 172.16.1.0 0.0.0.255 area 0  
!  
ip classless  
!  

--GWSwitch--

spanning-tree mode pvst  
spanning-tree extend system-id  
!  
interface FastEthernet0/1  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/2  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/3  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/4  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/5  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/6  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/7  
 switchport access vlan 20  
 switchport mode access  
!   
interface FastEthernet0/8  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/9  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/10  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/11  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/12  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/13  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/14  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/15  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/16  
!  
interface FastEthernet0/17  
!  
interface FastEthernet0/18  
!  
interface FastEthernet0/19  
!  
interface FastEthernet0/20  
!  
interface FastEthernet0/21  
!  
interface FastEthernet0/22  
!  
interface FastEthernet0/23  
!  
interface FastEthernet0/24  
!  
interface GigabitEthernet0/1  
 switchport trunk native vlan 99  
 switchport mode trunk  
!  
interface GigabitEthernet0/2  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
!  
!  
!  
line con 0  
!  
line vty 0 4  
 login  
line vty 5 15  
 login  
!  
!  
!  
!  
end  

--Branch Router--

ip dhcp excluded-address 192.168.1.0 192.168.1.5  
ip dhcp excluded-address 202.188.1.0 202.188.1.5  
ip dhcp excluded-address 172.16.1.0 172.16.1.5  
!  
ip dhcp pool ADMIN  
!  
!  
!  
no ip cef  
no ipv6 cef  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
spanning-tree mode pvst  
!  
!  
!  
!  
!  
!  
interface GigabitEthernet0/0/0  
 no ip address  
 duplex auto  
 speed auto  
!  
interface GigabitEthernet0/0/0.10  
 encapsulation dot1Q 10  
 ip address 192.168.1.2 255.255.255.0  
 ip helper-address 10.0.0.1  
!  
interface GigabitEthernet0/0/0.20  
 encapsulation dot1Q 20  
 ip address 202.188.1.2 255.255.255.0  
 ip helper-address 10.0.0.1  
!  
interface GigabitEthernet0/0/0.30  
 encapsulation dot1Q 30  
 ip address 172.16.1.2 255.255.255.0  
 ip helper-address 10.0.0.1  
!  
interface GigabitEthernet0/0/1  
 no ip address  
 duplex auto  
 speed auto  
 shutdown  
!  
interface GigabitEthernet0/0/2  
 no ip address  
 duplex auto  
 speed auto  
 shutdown  
!  
interface Serial0/1/0  
 ip address 10.0.0.2 255.255.255.252  
!  
interface Serial0/1/1  
 no ip address  
 clock rate 2000000  
 shutdown  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
router ospf 1  
 router-id 2.2.2.2  
 log-adjacency-changes  
 network 10.0.0.0 0.0.0.3 area 0  
 network 192.168.1.0 0.0.0.255 area 0  
 network 202.188.1.0 0.0.0.255 area 0  
 network 172.16.1.0 0.0.0.255 area 0  
!  

--BSwitch--

interface FastEthernet0/1  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/2  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/3  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/4  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/5  
 switchport access vlan 10  
 switchport mode access  
!  
interface FastEthernet0/6  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/7  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/8  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/9  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/10  
 switchport access vlan 20  
 switchport mode access  
!  
interface FastEthernet0/11  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/12  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/13  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/14  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/15  
 switchport access vlan 30  
 switchport mode access  
!  
interface FastEthernet0/16  
!  
interface FastEthernet0/17  
!  
interface FastEthernet0/18
!  
interface FastEthernet0/19  
!  
interface FastEthernet0/20  
!  
interface FastEthernet0/21  
!  
interface FastEthernet0/22  
!  
interface FastEthernet0/23  
!   
interface FastEthernet0/24  
!  
interface GigabitEthernet0/1  
 switchport mode trunk  
!  
interface GigabitEthernet0/2  
!  
3
  • 2
    You are using duplicate addressing on each side. That will not work unless you jump through some hoops. The VLANs on one side are not the VLANS on the other side despite the same VLAN numbers, because the are separate by layer-3 (router). You cannot use duplicate addressing. Change the addressing on one side.
    – Ron Maupin
    Commented Aug 28, 2021 at 12:04
  • CCNA practice task? Commented Sep 1, 2021 at 2:47
  • Did any answer help you? if so, you should accept the answer so that the question does not keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Commented Dec 23, 2021 at 21:10

1 Answer 1

2

Thought it might be beneficial to others to expand @Ron Maupin's comment to an actual answer.

What happens with the stated configuration is as follows:

  1. A guest connects to VLAN 30 in Branch network and broadcasts a DHCP Discover packet
  2. Branch switch floods the Disc packet
  3. Brand router receives it, and as instructed by the IP Helper config forwards the packet to Gateway router
  4. Gateway acting as DHCP server will respond with DHCP Offer
  5. Because the Gateway server sees network 172.16.1.0/24 as locally connected on g0/0/0.30, it will not forward the packet through s0/1/0, but through g0/0/0.30
  6. Devices in the main office VLAN 30 will receive the DHCP Offer, but since they didn't request it they will drop the packet

As Ron says, changing the IP addressing on one side is the solution. Using the current devices and IP ranges it means splitting the networks.

How to go on from there depends. If all devices in the main office use static IP addressing, the existing DCHP pools and reservations can just be changed to provide IPs in range x.x.x.128/25. All addresses in x.x.x.0/25 are then available in the main office, and devices in the branch office will receive IPs starting (for example) from x.x.x.130/25.

If, on the other hand, also main office requires DHCP services, it's necessary to change the existing pools to ranges x.x.x.0/25, and create new pools in ranges x.x.x.128/25 for the branch use.

EDIT

Oops! Routing! OSPF needs to be reconfigured to reflect the new network configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.