2

Today i connected the Starlink dish to an Cisco ISO-XE Box (ISR1111) as a secondary wan link and noticed some strange behavior.

I installed a static host-Route to an VPN Tunnel endpoint via

ip route x.x.x.x 255.255.255.255 dhcp

which works fine. The Route to the destination network is installed in the routing table with Starlinks CGN IP 100.127.something.something Next-Hop. Due to our Coverage is not stable it sometimes happen that Dishy is loosing Satellite connection and the routes including the implicit DHCP default-route are deleted. After the Connection is back the default route is reinstalled, but the static configured host routes are not.

Router#sh ip route 9.9.9.9
Routing entry for 9.9.9.9/32
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 100.127.255.3
      Route metric is 0, traffic share count is 1

"deb ip routing" shows:

*Sep  2 19:09:01.179: RT: del 9.9.9.9 via 100.127.255.3, static metric [1/0]
*Sep  2 19:09:01.180: RT: delete subnet route to 9.9.9.9/32
*Sep  2 19:09:01.180: RT: updating static 0.0.0.0/0 (0x0) [local lbl/ctx:1048577/0x0] omp-tag:0  :
    via 0.0.0.0 Tu1  0 1048578 0x100001

*Sep  2 19:09:01.180: RT: updating static 0.0.0.0/0 (0x0) [local lbl/ctx:1048577/0x0] omp-tag:0  :
    via 100.127.255.3   0 1048578 0x100001

*Sep  2 19:09:01.180: RT: rib update return code: 17

At first i supposed some sort of Bug, but even after trying several IOS Versions the issue is still the same. Any ideas here?

5
  • 2
    Yes, bug. Notify TAC. It might be fixed in a few years. (there are lots of bugs tied to DHCP addressing.)
    – Ricky
    Sep 2, 2021 at 21:02
  • 2
    Is there any change in behaviour if you include the intended egress interface, as in ip route x.x.x.x 255.255.255.255 <egressIF> dhcp ? Sep 2, 2021 at 21:39
  • there is no change in this behavior when binding the Route to a Interface or not. I'm wondering why i stumple upon this "bug" just with Starlink's DHCP, i have several quite similar configurations that are running fine for years. Sep 3, 2021 at 5:13
  • After reading your question multiple times, there seem to be a couple ways to understand the question. Can you add clarity? Sounds like there is a private WAN circuit as primary, but satellite internet as backup? Can we assume private circuit is statically addressed and satellite is DHCP? Does Dishy=Starlink? Nov 3, 2021 at 18:55
  • Has any answer solved your question? Then please accept it or your question will keep popping up here forever. Please also consider voting for useful answers.
    – Zac67
    Jan 1 at 10:53

1 Answer 1

-1

Configure Static route within including the CE interface of the ISR1100

ip route x.x.x.x 255.255.255.255 Gi0/0 dhcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.