-1

Consider the following network

enter image description here

I can ping just fine from PC0 to PC1 and PC2 to PC3, but I can't ping from PC2 to PC1 or PC3 to PC0. Why? I'll share the configuration from the router:

Building configuration...

Current configuration : 818 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname escuela
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15249C5H-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Here's the IP table:

enter image description here

2

according to your configuration, all your PCs are in the same local area (layer 2) network aka subnet. Since they think they are in the same subnet they think they should reach each other using layer 2 and do not use layer 3 to communicate. This communication fails since they actually can't reach each other.

also, router interface and two PCs that are connected to the same switch should be in the same subnet. Subnet is determined by what can be reached by switches, not the router.

and finally, each PC should have default gateway configured on it.

4
  • thanks, I have changed the PC IPs to be in the same IP range as 192.168.1.X and 2.X respectively. but I still get an error. what could be wrong? Sep 11 at 21:57
  • is default gateway configured on PCs?
    – Effie
    Sep 11 at 22:03
  • YES, I forgot about the default gateway!!! thank you so much! Sep 11 at 22:10
  • 1
    could you edit the answer and say what exactly should be in "default gateway"?
    – Effie
    Sep 11 at 22:17
1

The router is using the addresses 192.168.1.1/24 and 192.168.2.1/24 on its interfaces. These are the subnets that the PCs need to be member of as well.

As it is, no PC from 192.168.3.0/24 can talk to any router interface.

Also, all PCs think they're on the same subnet, so they won't try to use the gateway. Put another way, they're in the same IP subnet but not in the same Ethernet segment. A mismatch like that breaks your network.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.