0

My issue is very similar to this link: Dell PowerConnect 5524 VLAN routing

I have several VLANs

But most importantly VLAN 1 is the flat 192.168.69.0/24 VLAN 10 is 192.168.0.0/16 VLAN 110 is 10.1.10.0/24 VLAN 80 is 10.0.80.0/24 VLAN 90 is 10.0.90.0/24

Before trying to get VLAN 110 to talk to VLAN 80 I can't even get it talk to the default VLAN 1

The way my configure right now, I can SSH in to the powerconnect (192.168.69.10) and it will ping the ip assigned to the VLAN 110 interface (10.1.10.254). Since my VLAN 1 is enable to talk to 10.1.10.254 I can't even get the DHCP scope. Anyway currently te1/0/1 is set to switchport access vlan 110. Physically the powerconnect SPF port is connected to a non-manageable SPF switch. And I have several PC on that non-manageable switch. I manually static assigned one of the PC to 10.1.10.48 and 10.1.10.254 as default gateway.

Here are some of the findings. I am able to ping 192.168.69.10 (PowerConenct switch) and 10.1.10.254 from the PC on the unmanaged switch. While in the SSH session of the PowerConnect switch I am able to ping 10.1.10.254 (VLAN 110 interface IP) and 10.1.10.48 (PC on the unmanaged switch). HOWEVER! I am not able to ping anything else on 192.168.69.0 from the PC.

I am not sure if it is the problem with the Static route on the Powerconnect Switch

console(config)# do show ip route
Maximum Parallel Paths: 1 (1 after reset)
IP Forwarding:          enabled

Codes: C - connected, S - static, D - DHCP

S  0.0.0.0/0          [1/1] via  192.168.69.1  47:34:12            vlan 1
C  10.1.10.0/24       is directly connected                        vlan 110
C  192.168.69.0/24    is directly connected                        vlan 1

From the PowerConnect switch I can ping any 192.168.69.0 devices.

Here is the config:

console(config-if)# do show run
    spanning-tree priority 4096
    port jumbo-frame
    bridge multicast filtering
    vlan database
    vlan 10,80,90,110
    exit
    voice vlan oui-table add 000181 Nortel__________________
    voice vlan oui-table add 0001e3 Siemens_AG_phone________
    voice vlan oui-table add 00036b Cisco_phone_____________
    voice vlan oui-table add 00096e Avaya___________________
    voice vlan oui-table add 000fe2 H3C_Aolynk______________
    voice vlan oui-table add 001049 Shoretel________________
    voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
    voice vlan oui-table add 00907a Polycom/Veritel_phone___
    voice vlan oui-table add 00e0bb 3Com_phone______________
    ip igmp snooping
    ip igmp snooping vlan 1
    ip dhcp snooping
    ip dhcp snooping vlan 110
    ip igmp snooping vlan 1 querier
    ip igmp snooping vlan 1 querier address 192.168.69.10
    iscsi target port 860 address 0.0.0.0
    iscsi target port 3260 address 0.0.0.0
    iscsi target port 9876 address 0.0.0.0
    iscsi target port 20002 address 0.0.0.0
    iscsi target port 20003 address 0.0.0.0
    iscsi target port 25555 address 0.0.0.0
    green-ethernet short-reach
    ip dhcp relay address 192.168.69.5
    ip dhcp relay enable
    username admin password encrypted ae64a36fb23af8953a5998a5cda9f786037182a2 pr
    ivilege 15
    ip ssh server
    snmp-server community Dell_Network_Manager rw 192.168.69.9 view DefaultSuper
    clock timezone GMT -6
    clock summer-time GMT recurring usa
    sntp anycast client enable
    sntp broadcast client enable
    clock source sntp
    sntp unicast client enable
    sntp unicast client poll
    sntp server 66.228.48.38 poll
    ip name-server  192.168.69.5 192.168.69.3
    no ip telnet server
    !
    interface vlan 1
     ip address 192.168.69.10 255.255.255.0
     ip dhcp relay enable
    !
    interface vlan 10
     name iSCSI
    !
    interface vlan 80
     name "Samba Fileshares"
     ip address 10.0.80.254 255.255.255.0
    !
    interface vlan 90
     name "NFS Fileshares"
     ip address 10.0.90.254 255.255.255.0
    !
    interface vlan 110
     name Den
     ip address 10.1.10.254 255.255.255.0
     ip dhcp relay enable
    !
    interface gigabitethernet1/0/1
     no eee enable
     flowcontrol off
     no eee lldp enable
    !
    interface gigabitethernet1/0/13
     no mdix
     flowcontrol off
     no negotiation
     description "Basement Livingroom"
    !
    interface gigabitethernet1/0/14
     description "Basement Master"
    !
    interface gigabitethernet1/0/16
     no eee enable
     no negotiation
     no eee lldp enable
    !
    interface gigabitethernet1/0/29
     no eee enable
     no eee lldp enable
    !
    interface gigabitethernet1/0/31
     no eee enable
     no eee lldp enable
     switchport mode general
     switchport general allowed vlan add 10 tagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/32
     switchport mode general
     switchport general allowed vlan add 10 untagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/33
     no eee enable
     no eee lldp enable
     switchport mode general
     switchport general allowed vlan add 10 tagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/34
     switchport mode general
     switchport general allowed vlan add 10 untagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/35
     no eee enable
     no eee lldp enable
     switchport mode general
     switchport general allowed vlan add 10 tagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/36
     switchport mode general
     switchport general allowed vlan add 1 tagged
     switchport general allowed vlan add 10 untagged
     switchport general pvid 10
    !
    interface gigabitethernet1/0/40
     no mdix
     flowcontrol off
    !
    interface gigabitethernet1/0/42
     no eee enable
     no mdix
     flowcontrol off
     no negotiation
     no eee lldp enable
     green-ethernet short-reach
    !
    interface gigabitethernet1/0/43
     no mdix
     spanning-tree portfast
     spanning-tree cost 200000
     spanning-tree guard root
     spanning-tree bpduguard enable
    !
    interface gigabitethernet1/0/45
     no eee enable
     flowcontrol off
     channel-group 1 mode auto
     no eee lldp enable
     green-ethernet short-reach
    !
    interface gigabitethernet1/0/47
     no eee enable
     flowcontrol off
     channel-group 1 mode auto
     no eee lldp enable
     green-ethernet short-reach
    !
    interface tengigabitethernet1/0/1
     speed 1000
     description "Den VLAN 110"
     switchport general allowed vlan add 1,110 untagged
     switchport access vlan 110
     switchport general pvid 110
    !
    interface Port-channel1
     speed 1000
     flowcontrol auto
    !
    interface Port-channel2
     speed 1000
     flowcontrol off
    !
    ip route 0.0.0.0 0.0.0.0 192.168.69.1
    
    
    
    
    
    
    Default settings:
    Service tag: 2MW17M1
    
    SW version 4.1.0.24 (date  01-Sep-2020 time  14:40:38)
    
    Gigabit Ethernet Ports
    =============================
    no shutdown
    speed 1000
    duplex full
    negotiation
    flow-control on
    mdix auto
    no back-pressure
    
    interface vlan 1
    interface port-channel 1 - 32
    
    spanning-tree
    spanning-tree mode RSTP
    
    qos basic
    qos trust cos
    eee enable

on my main router (192.168.69.1) has static route 10.1.10.0/24 to destination 192.168.69.10 (PowerConnect)

0

VLAN 1 is the flat 192.168.69.0/24 VLAN 10 is 192.168.0.0/16

192.168.69.0/24 is a subnet of 192.168.0.0/16, making your routing ambiguous. You'll need to separate that properly, ie. without overlap.

0

I figured it out. My Main router AX89X I fat fingered an entry in there for the static route. Fixed it and bammmm all the subnet is routing now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.