2

Trying to setup an ethernet link from CE located in building A to CE in building B. Customer may or may not tag it's frames sent over the link. Here's the setup I am trying to use

+----+       +--------+      +----------+             +----------+  
| CE +--(A)--+ EX4200 +-(B)--+ Router A +---(L2VPN)---+ Router B + 
+----+       +--------+      +----------+             +----------+  

Where on link A Customer may either send tagged frames with arbitrary VLAN-ID or untagged frames. On Link B frames are outer tagged with S-Tag. I am not even worrying about the L2VPN part.

In lab I send tagged frames to EX4200. The port facing CE is configured as access port with vlan member designated S-Tag

set interfaces ge-0/0/22 unit 0 family ethernet-switching port-mode access

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members qinq

vlan qinq is configured like this:

set vlans qinq vlan-id 100
set vlans qinq dot1q-tunneling customer-vlans native
set vlans qinq dot1q-tunneling customer-vlans 1-4094
set ethernet-switching-options dot1q-tunneling ether-type 0x8100

Trunk towards router:

set interfaces xe-0/1/0 unit 0 family ethernet-switching port-mode trunk
set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members qinq

To test IP connectivity I send ping from CE to Router A. If I send untagged frames I get IP connectivity. Once I send tagged frames towards EX4200 there's no packets going out on either interfaces.

What am I missing?

5
  • The routers will need to support and be configured for QinQ frames. Alternatively, they need to support fully transparent bridging across the VPN link.
    – Zac67
    Oct 8, 2021 at 15:08
  • I am not seeing any frames leave the EX-4200 so I am not worrying about the routers. Traffic statistics: Current delta Input bytes: 4551453 (512 bps) [2112] Output bytes: 1319116 (0 bps) [316] Input packets: 56775 (1 pps) [33] Output packets: 5545 (0 pps) [1] stats while ping from CE to Router A is running. Thanks for the hint though. I'll keep that in mind!
    – chrpenguin
    Oct 8, 2021 at 16:06
  • EoMPLS is an easier way to deliver this service than QinQ. If you're able to extend your MPLS domain out to the EX4200 as a regular PE, do that instead. Oct 8, 2021 at 18:10
  • Unfortunately, I don't think that is an actual option. However, if that service cannot be delivered with Q in Q, then I will indeed have to extend MPLS domain. Would love to find a way to do it though
    – chrpenguin
    Oct 10, 2021 at 7:51
  • Did any answer help you? if so, you should accept the answer so that the question does not keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Dec 23, 2021 at 22:33

1 Answer 1

2

Ah yes, the highly confusing world of Q-in-Q configuration on the EX switche - we meet again.

Try making the following changes to your config:

delete interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members qinq
delete interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members qinq
set vlans qinq interface ge-0/0/22.0
set vlans qinq interface xe-0/1/0.0

I've never had much luck making Q-in-Q work using the common "VLANs configured under interfaces" hierarchy (even though there are examples on the web showing it done this way), but if you switch to the "Interfaces under VLANs" way of doing it (as above), you should be fine.

This might also be helpful:

Juniper EX4200 QinQ question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.