4

I have a few N540-ACC-SYS (XR 7.3.1) where ZTP works fine with ztp initiate interface Ten0/0/0/0. The challenge also exists on 7.2.2.

I'm at the point of doing the final test to validate proper working when rebooting the system. I'm trying the following sequence to make the system factory default. Without success.

conf t
commit replace
exit
admin
hw-module location all reload force

I also tried commit replace best-effort.

The system boots properly (i see the BIOS banner Version 2.18.1260. Copyright (C) 2019 American Megatrends, Inc. (which is as good as a cold boot)), however, it does not initiate the ZTP process (taking the 10min ZTP timer into consideration). The router just sits at this point:

LC/0/0/CPU0:Oct 21 12:20:26.235 UTC: tam_entropy[324]: %SECURITY-TAMSVCS-3-ENTROPY : Shutting down tam_entropy process for Software TAM based devices. 

"When a device that supports Zero-Touch Provisioning boots up, and does not find the startup configuration (during fresh install on Day Zero), the device enters the Zero-Touch Provisioning mode."

My assumption is that by doing a commit replace, the config is wiped but still seems to leave a startup config/startup config file.

Update:

  1. The quote ("When a device that....") is taken from a cat3850 (IOS-XE). source: https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3850/software/release/16-5/configuration_guide/prog/b_165_prog_3850_cg/zero_touch_provisioning.pdf Knowing Cisco, the implementation might be different for other platforms/Software types. When looking at this doc https://xrdocs.io/device-lifecycle/tutorials/2016-08-26-working-with-ztp/ " At the beginning of its execution, ZTP will scan the configuration for the presence of a username. If there are no username configured, ZTP will fork a DHCP client on the management interface for IPv4 and IPv6 simultaneously, and wait for a response."

There seems to be more to "not having a username configured" as the behavior shows.

/update

Before i start to remove files, how to proceed with this? Do i also perform a commit replace in the admin context? How do i get the device in a proper state for ZTP to initiate after a full reload? Am i missing something? Thank you in advance.

1
  • 1
    If you solved the problem, please add an answer and accept it so that the question does not keep popping up forever, looking for an answer.
    – Ron Maupin
    Oct 27 at 12:50
5

Problem Found! Cisco Bug in 7.3.1 The issue was me not executingztp clean

Initially tested this on 7.3.1. where this command did not have any effect. Decided to also run this on a NCS running 7.2.2. lo and behold!!

RP/0/RP0/CPU0:Oct 27 12:18:56.181 UTC: pyztp2[69430]: %INFRA-ZTP-6-PROVISIONING_COMPLETED : Provisioning successful 
RP/0/RP0/CPU0:Oct 27 12:18:59.429 UTC: pyztp2[69430]: %INFRA-ZTP-6-EXITED : ZTP exited

So, this must be a bug in XR 7.3.1 software. So for all, who needs to know, the procedure.. tried and true

ztp clean
conf t
commit replace
exit
admin
hw-module location all reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.