3

I am new with Juniper and generally new with switch configuration. Probably screwed up a lot but anyways, I will share my configuration right after I say what I want. I am getting Internet on configured ports, so that side works, however, I need a better way to configure them all, add storm-control to them and I have no idea how to do that. I also need your advice if anything is missing. I have configured the switch like this:

Last changed: 2021-10-26 09:42:54 CEST version 20.4R3.8; system {

host-name Juniper-Rechts;
root-authentication {
    encrypted-password "insert random gibberish";
}
services {
    ssh {
        root-login allow;
        protocol-version v2;
    }
    netconf {
        ssh;
    }
    dhcp-local-server {
        traceoptions {
            file jdhcplog;
            flag all;
        }
    }
    web-management {
        http;
    }
}
domain-name gov.intra;
domain-search gov.intra;
backup-router 10.13.69.1;
time-zone Europe/Berlin;
name-server {
    10.5.8.11;
    10.5.8.10;
}
syslog {
    user * {
        any emergency;
    }
    file messages {
        any notice;
        authorization info;
    }
}
ntp {
    server 162.159.200.123 prefer;
} } interfaces {
ge-0/0/0 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/1 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/2 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/3 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/4 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/5 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/6 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/7 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/8 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/9 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/10 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/11 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/12 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/13 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/14 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/15 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/16 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/17 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/18 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/19 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/20 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/21 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/22 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/23 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/24 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/25 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/26 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/27 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/28 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/29 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/30 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/31 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/32 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/33 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/34 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/35 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/36 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/37 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/38 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/39 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/40 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/41 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/42 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/43 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/44 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/45 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/46 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
ge-0/0/47 {
    apply-macro juniper-port-profile {
        Default;
    }
    speed auto;
    link-mode full-duplex;
    ether-options {
        auto-negotiation;
        no-flow-control;
    }
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }
}
vme {
    unit 0 {
        family inet {
            address 10.13.69.94/24;
        }
    }
} } forwarding-options {
storm-control-profiles sc {
    all {
        bandwidth-level 15000;
    }
} } access {
address-assignment {
    pool DHCP-Desno {
        family inet {
            network 10.13.69.0/24;
            range limited {
                low 10.13.69.2;
                high 10.13.69.253;
            }
        }
    }
} } routing-options {
static {
    route 0.0.0.0/0 next-hop 10.13.69.1;
} } protocols {
lldp {
    interface all;
}
lldp-med {
    interface all;
}
igmp-snooping {
    vlan all;
} } switch-options {
voip {
    interface ge-0/0/0.0 {
        vlan mgmt;
    }
    interface ge-0/0/1.0 {
        vlan mgmt;
    }
    interface ge-0/0/2.0 {
        vlan mgmt;
    }
    interface ge-0/0/3.0 {
        vlan mgmt;
    }
    interface ge-0/0/4.0 {
        vlan mgmt;
    }
    interface ge-0/0/5.0 {
        vlan mgmt;
    }
    interface ge-0/0/6.0 {
        vlan mgmt;
    }
    interface ge-0/0/7.0 {
        vlan mgmt;
    }
    interface ge-0/0/8.0 {
        vlan mgmt;
    }
    interface ge-0/0/9.0 {
        vlan mgmt;
    }
    interface ge-0/0/10.0 {
        vlan mgmt;
    }
    interface ge-0/0/11.0 {
        vlan mgmt;
    }
    interface ge-0/0/12.0 {
        vlan mgmt;
    }
    interface ge-0/0/13.0 {
        vlan mgmt;
    }
    interface ge-0/0/14.0 {
        vlan mgmt;
    }
    interface ge-0/0/15.0 {
        vlan mgmt;
    }
    interface ge-0/0/16.0 {
        vlan mgmt;
    }
    interface ge-0/0/17.0 {
        vlan mgmt;
    }
    interface ge-0/0/18.0 {
        vlan mgmt;
    }
    interface ge-0/0/19.0 {
        vlan mgmt;
    }
    interface ge-0/0/20.0 {
        vlan mgmt;
    }
    interface ge-0/0/21.0 {
        vlan mgmt;
    }
    interface ge-0/0/22.0 {
        vlan mgmt;
    }
    interface ge-0/0/23.0 {
        vlan mgmt;
    }
    interface ge-0/0/24.0 {
        vlan mgmt;
    }
    interface ge-0/0/25.0 {
        vlan mgmt;
    }
    interface ge-0/0/26.0 {
        vlan mgmt;
    }
    interface ge-0/0/27.0 {
        vlan mgmt;
    }
    interface ge-0/0/28.0 {
        vlan mgmt;
    }
    interface ge-0/0/29.0 {
        vlan mgmt;
    }
    interface ge-0/0/30.0 {
        vlan mgmt;
    }
    interface ge-0/0/31.0 {
        vlan mgmt;
    }
    interface ge-0/0/32.0 {
        vlan mgmt;
    }
    interface ge-0/0/33.0 {
        vlan mgmt;
    }
    interface ge-0/0/34.0 {
        vlan mgmt;
    }
    interface ge-0/0/35.0 {
        vlan mgmt;
    }
    interface ge-0/0/36.0 {
        vlan mgmt;
    }
    interface ge-0/0/37.0 {
        vlan mgmt;
    }
    interface ge-0/0/38.0 {
        vlan mgmt;
    }
    interface ge-0/0/39.0 {
        vlan mgmt;
    }
    interface ge-0/0/40.0 {
        vlan mgmt;
    }
    interface ge-0/0/41.0 {
        vlan mgmt;
    }
    interface ge-0/0/42.0 {
        vlan mgmt;
    }
    interface ge-0/0/43.0 {
        vlan mgmt;
    }
    interface ge-0/0/44.0 {
        vlan mgmt;
    }
    interface ge-0/0/45.0 {
        vlan mgmt;
    }
    interface ge-0/0/46.0 {
        vlan mgmt;
    }
    interface ge-0/0/47.0 {
        vlan mgmt;
    }
} } vlans {
default {
    vlan-id 1;
}
mgmt {
    description "MANAGEMENT PORT";
    vlan-id 100;
} }

Please give me assistance on what to do. I am completely lost, it's been days.

1
  • Has any answer solved your question? Then please accept it or your question will keep popping up here forever. Please also consider voting for useful answers.
    – Zac67
    Aug 5, 2023 at 7:33

1 Answer 1

0
system {
    host-name Juniper-Rechts;
    root-authentication {
        encrypted-password "insert random gibberish";
    }
    services {
        ssh {
            root-login allow;
            protocol-version v2;
        }
        netconf {
            ssh;
        }
        dhcp-local-server {
            traceoptions {
                file jdhcplog;
                flag all;
            }
        }
        web-management {
            http;
        }
    }
    domain-name gov.intra;
    domain-search gov.intra;
    backup-router 10.13.69.1;
    time-zone Europe/Berlin;
    name-server {
        10.5.8.11;
        10.5.8.10;
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
    }
    ntp {
        server 162.159.200.123 prefer;
    }
}

interfaces {
    apply-macro juniper-port-profile {
        Default;
    }
    
    ge-0/0/0 {
        speed auto;
        link-mode full-duplex;
        ether-options {
            auto-negotiation;
            no-flow-control;
        }
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members default;
                }
            }
        }
        storm-control {
            default-profile;
        }
    }
    
    ge-0/0/1 {
        speed auto;
        link-mode full-duplex;
        ether-options {
            auto-negotiation;
            no-flow-control;
        }
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members default;
                }
            }
        }
        storm-control {
            default-profile;
        }
    }
    
    ge-0/0/2 {
        speed auto;
        link-mode full-duplex;
        ether-options {
            auto-negotiation;
            no-flow-control;
        }
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members default;
                }
            }
        }
        storm-control {
            default-profile;
        }
    }
    
    // Repeat the above block for other interfaces (ge-0/0/3 to ge-0/0/21)
}

protocols {
    lldp {
        interface all;
    }
    rstp;
    igmp-snooping;
    storm-control {
        profile default-profile {
            bandwidth-level 75;
        }
    }
}

Modify each interface configuration to include storm-control and assign them to the desired VLANs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.