3

I have this network topology in Packet Tracer, and i wanted to implement HSRP on both of the multilayer switches. enter image description here

So what i made here is the switch on the left, both the laptop and the server are on VLAN 10, the laptop on the right hand its working on VLAN 20. I've configured trunking between switches and the router at the bottom (switch module installed on it, so its actually acting like a switch).

On the multilayer switches i assigned an ip address for each vlan, configured standby and enabled ip routing.

I've checked the routing tables and they're empty, but i think that they should have some routes configured dynamically, such as the directly connected ones. Am i missing something? Should i put static routes or something?

NOTE: With both of the laptops, i cant even ping the HSRP gateway.

LEFT MLS CONFIGURATION:

Building configuration...

Current configuration : 2189 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree vlan 1-30 priority 24576
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 0030.a378.b901
 ip address 192.168.10.254 255.255.255.0
 standby version 2
 standby 10 ip 192.168.10.100
 standby 10 priority 110
 standby 10 preempt
!
interface Vlan20
 mac-address 0030.a378.b902
 ip address 192.168.20.254 255.255.255.0
 standby version 2
 standby 20 ip 192.168.20.200
 standby 20 priority 110
 standby 20 preempt
!
interface Vlan30
 mac-address 0030.a378.b903
 ip address 192.168.30.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

RIGHT MLS CONFIGURATION:

Building configuration...

Current configuration : 2168 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree vlan 1-30 priority 28672
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 0060.2fa3.4d01
 ip address 192.168.10.253 255.255.255.0
 standby version 2
 standby 10 ip 192.168.10.100
 standby 10 priority 90
 standby 10 preempt
!
interface Vlan20
 mac-address 0060.2fa3.4d02
 ip address 192.168.20.253 255.255.255.0
 standby 20 ip 192.168.20.200
 standby 20 priority 90
 standby 20 preempt
!
interface Vlan30
 mac-address 0060.2fa3.4d03
 ip address 192.168.30.2 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

LEFT SWTICH CONFGIURATION:

Building configuration...

Current configuration : 1353 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
 switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
!
interface Vlan20
 description VLAN20
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

RIGHT SWITCH CONFIGURATION:

Building configuration...

Current configuration : 1282 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
!
interface Vlan20
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

ROUTER CONFIGURATION:

Building configuration...

Current configuration : 2166 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017G8V4-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 switchport mode trunk
!
interface FastEthernet1/1
 switchport mode trunk
!
interface FastEthernet1/2
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/3
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/4
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/5
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/6
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/7
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/8
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/9
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/10
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/11
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/12
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/13
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/14
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface FastEthernet1/15
 switchport mode access
 switchport nonegotiate
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 0007.ec9a.a101
 no ip address
!
interface Vlan20
 mac-address 0007.ec9a.a102
 no ip address
!
interface Vlan30
 mac-address 0007.ec9a.a103
 ip address 192.168.30.3 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

LEFT LAPTOP: enter image description here

RIGHT LAPTOP: enter image description here

I've not configured the server just yet, because i want all the things working withn static IPs, and once everything its working i will configure DHCP.

MLS VLAN BRIEF:

Switch#sh vlan brief 

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gig1/0/6, Gig1/0/7, Gig1/0/8, Gig1/0/9
                                                Gig1/0/10, Gig1/0/11, Gig1/0/12, Gig1/0/13
                                                Gig1/0/14, Gig1/0/15, Gig1/0/16, Gig1/0/17
                                                Gig1/0/18, Gig1/0/19, Gig1/0/20, Gig1/0/21
                                                Gig1/0/22, Gig1/0/23, Gig1/0/24, Gig1/1/1
                                                Gig1/1/2, Gig1/1/3, Gig1/1/4
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

LEFT SWITCH VLAN BRIEF:

Switch#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig0/1, Gig0/2
10   VLAN0010                         active    Fa0/1, Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active

RIGHT SWITCH VLAN BRIEF:

Switch#sh vlan brief 

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gig0/1, Gig0/2
20   VLAN0020                         active    Fa0/1
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active
2
  • Let's start with basics: Can you ping the vlan interface (physical) from the laptops?
    – Ron Trunk
    Nov 1, 2021 at 12:16
  • I do not reach any of the 254 or 253 IPs assigned to the vlan interface on the switch from any of the laptops.
    – 1511
    Nov 1, 2021 at 12:28

1 Answer 1

4

Looking at the config have you created the vlans? I can see the vlan interfaces configured but the running-config doesnt show any vlan config that would create the vlan.

show vlan brief and see if the vlans are listed on each switch.

EDIT - In global configuration mode issue the command vlan vlan-id eg vlan 10. That will create the vlan on the switch.

9
  • Added the command output to the question, is it normal that in the MLS i do not get any of the vlans created on the switch?
    – 1511
    Nov 1, 2021 at 12:31
  • No. You need to create the VLANs on the MLS switches
    – Ron Trunk
    Nov 1, 2021 at 12:42
  • show spanning-tree vlan x will also show you if the vlans exist on the switch.
    – Ron Trunk
    Nov 1, 2021 at 13:13
  • You are right, when i do a show vlan id 10 i get this output VLAN id 10 not found in current VLAN database. Maybe it's a dumb question, but how do i create a vlan when it is not assigned to any interface? Because all the interfaces are trunking on the switch.
    – 1511
    Nov 1, 2021 at 14:02
  • in the general config mode you issue the command vlan 10. That should be all you have to do. Nov 1, 2021 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.