1

I'm trying to upgrade the firmware on my J9450A HP 1810-24G Switch, which presently has firmware P.1.6, eCos-2.0

The firmware-update-for-an-1810 question is out there on the internet, but the solution is not.

I access the switch-interface via browser (192.168.2.10).

I can ping my laptop using the switch-interface.

Buffered logging is enabled.

From the Maintenance > Update-Manager, I select update-method = HTTP, browse = p.1.20.stk, update-type = code, Image = active, followed by download, nothing happens, no log entry.

Again from the Maintenance > Update-Manager, I select update-method = HTTP, browse = p.1.20.stk, update-type = code, Image = backup, followed by download, a window popup saying

"Warning data transfer will take a few minutes ... Do not disturb the browser ... After the operation is complete, please view Status > log page for transfer status "

followed by another popup saying

Note: In order to boot with the upgraded image .....

After waiting 10 minutes, I click on the switch-interface, which changes to the login page. I go to the Status > log and see no change.

In the Maintenance > Dual Image Configuration, I try to activate image2, but nothing is there.

What do I do?

Thank you.

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Nov 19, 2022 at 22:44

1 Answer 1

0

The current 1810Gv1 firmware is P.2.24 - but you need to flash P.1.20 first, as you've been trying. Perhaps you should re-download the file (all downloads up to P.2.18 include P.1.20). If nothing works, try another browser.

You need to wait until the switch acknowledges the upload (you should see the transfer on your network) and then reboot. I used to have a couple of those 1810, updating was slightly awkward but worked all the time. (I think I even wrote a curl script to push updates...)

(NB: HPE Networking has transited to the Aruba Networks site - downloads are still available and free, just register to log in.)

4
  • I've tried Firefox, IE, and BING, no difference. I redownloaded the .stk files, no difference. After starting the download, the switch reboots after ~15 seconds and the file transfer never completes.
    – rih5342
    Nov 12, 2021 at 17:27
  • Funny - it's been a few years since I did that last P.1 update - P.1.6 is really ancient. Have you tried the oldest P.1.17 that's still on the HPE site? You're not updating remotely, are you? You can also try to delete the backup image first - I think that's under maintenance as well.
    – Zac67
    Nov 12, 2021 at 17:35
  • I incidentally got my hands on an 1810-24G with P.1.14 - the two-step update (-> P.1.20 -> reboot -> P.2.24 -> reboot) went without a hitch. If neither image1 nor image2 can be updated I'd start an RMA for the switch, they're still under warranty.
    – Zac67
    Dec 10, 2022 at 10:57
  • 1
    The software is now on Aruba Networks Software download portal. Just updated my switch to P.2.24 from P.2.2.12 Apr 6, 2023 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.