0

I have some issue with a cisco switch IE-3000: through the CISCO GUI I see that some port has from time to time auto negotiation process (port indication flashing with green-orange)

I know that I can see on the syslog the port up/down. Is there some command that I can issue on the CLI to see that the process of auto-negotiation starts/ends?

5
  • 1
    Despite what JFL said below, it does still happen in cases such as when you’re connecting switches together and one is a 10/100 model while the other is 10/100/1000. Without details about your environment such as a diagram and sanitized switch configs, the most we can do is guess at the issue (which is off limits here).
    – Jesse P.
    Nov 25, 2021 at 12:50
  • I know that both (switch and my equipment) are supporting 1G interface. More over, there are only 4 wires on the cable connected between them, so from the cisco side, it set the connection to 100, while when I'm checking on my equipment (linux yocto), it still displays 100 Nov 25, 2021 at 12:51
  • 1
    That’s fine. It was just an example of when it can happen. Like I said, without your configs or more details like what’s plugged in on the port(s) you see the issue with, all we can do is guess.
    – Jesse P.
    Nov 25, 2021 at 12:52
  • 3
    "More over, there are only 4 wires on the cable connected between them" this is your issue. You are not using a proper cable. You should change it with a certified cable.
    – JFL
    Nov 25, 2021 at 13:35
  • Did any answer help you? if so, you should accept the answer so that the question does not keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Dec 24, 2021 at 0:10

2 Answers 2

2

What we usually call auto-negotiation is the process by which 2 devices agree on the link speed and duplex. This is really fast (almost instant from a human point of view) and, while issue with this process was not rare a decade ago, it is quite uncommon nowodays.

Your issue is most probably with spanning-tree, which is enabled by default, in PVST+ mode, on those switches, with a delay of 15 seconds before a port goes to the forwarding state.

You should be able to see the status of the port with the command

show spanning-tree interface ethernet <your interface number>

(the exact syntax may vary, I'm not this familiar with those switches)

If this delay cause you some trouble you can configure the ports that are connected to end devices with the command spanning-tree portfast on the chose interfaces. This will instruct the switch to immediately transition the port to the forwarding state when the link connect.

1
  • Indeed. Green-Orange is STP learning. (solid orange is STP blocked.)
    – Ricky
    Nov 26, 2021 at 1:09
2

Connecting a non-standard 4-wire/2-pair cable (detail from comment) between 1000BASE-T ports does not normally work. You should not use those cables in general, or at least not in any connection with 1000BASE-T.

Auto negotiation just uses two pairs but when 1000BASE-T is mutually negotiated, all four pairs are required for the link to actually come up (the PCS sublayer negotiates each pair/lane separately).

With only two pairs, there are quite a few implementations that restart link negotiation for 10BASE-T/100BASE-TX, esp. Broadcom's Ethernet@Wirespeed - but that is not a standard and shouldn't be taken for granted. Some of these implementations periodically renegotiate and relink, possibly causing the exact situation you are experiencing.

You should replace the cable with a standard Cat 5e+ cable and dispose of the two-pair cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.