0
  1. Unable to get internet connectivity from non-default vlans.
  2. Suspect router config is not adequate
  3. Five vlans created on 2960 (10,20,30,40,50)and Gig port 0/1 set to trunk.
  4. Port f0 on router which is connected to switch port Gig 0/1 is set to trunk with dot1q
  5. Since port F0-3 on integrated service router are switch ports, sub-interfaces cant be setup.
  6. Vlan interfaces were setup on router in place of sub-interfaces

Any assistance or insight would be appreciated.

Cisco 871 Router Configuration

    Current configuration : 2635 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname xx871
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 095641001B171205
    !
    username xx871 password 7 0109090D59190318
    no aaa new-model
    ip subnet-zero
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.10
    !
    ip dhcp pool MYLAB
       import all
       network 192.168.1.0 255.255.255.0
       domain-name wr
       default-router 192.168.1.10
       dns-server 208.67.222.222 208.67.220.220
       lease 5
    !
    !
    ip domain name MYLAB.com
    ip ssh version 2
    no ftp-server write-enable
    !
    !
    !
    spanning-tree portfast bpduguard
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.0
     ip nat outside
     ip virtual-reassembly
    !
    interface FastEthernet0
     switchport trunk allowed vlan 1,2,10,20,30,40,50,1002-1005
     switchport mode trunk
     no ip address
     dot1q tunneling ethertype 0x9100
    !
    interface FastEthernet1
     no ip address
    !
    interface FastEthernet2
     no ip address
     shutdown
    !
    interface FastEthernet3
     no ip address
     shutdown
    !
    interface FastEthernet4
     ip address 10.0.0.100 255.255.255.0
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface Vlan1
     ip address 192.168.1.10 255.255.255.0
     ip nat inside
     ip virtual-reassembly
    !
    interface Vlan10
     ip address 192.168.10.254 255.255.255.0
    !
    interface Vlan20
     ip address 192.168.20.254 255.255.255.0
    !
    interface Vlan30
     ip address 192.168.30.254 255.255.255.0
    !
    interface Vlan40
     ip address 192.168.40.254 255.255.255.0
    !
    interface Vlan50
     ip address 192.168.50.254 255.255.255.0
    !
    router ospf 1
     router-id 1.1.1.0
     log-adjacency-changes
     auto-cost reference-bandwidth 1000
     passive-interface FastEthernet4
     network 10.0.0.0 0.255.255.255 area 0
     network 192.0.0.0 0.255.255.255 area 0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface FastEthernet4 overload
    !
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    access-list 100 permit ip 192.168.10.0 0.0.0.255 any
    access-list 100 permit ip 192.168.20.0 0.0.0.255 any
    access-list 100 permit ip 192.168.30.0 0.0.0.255 any
    access-list 100 permit ip 192.168.40.0 0.0.0.255 any
    access-list 100 permit ip 192.168.50.0 0.0.0.255 any
    !
    control-plane
    !
    
    !
    line con 0
     logging synchronous
     no modem enable
     transport preferred all
     transport output all
    line aux 0
     transport preferred all
     transport output all
    line vty 0 4
     login local
     transport preferred all
     transport input ssh
     transport output all
    !
    scheduler max-task-time 5000
    end      

2960 Switch Configuation

    Current configuration : 2977 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname xxS871
    !
    enable password zoibrew
    !
    username xxs871 password 0 xxxxx
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    !
    ip domain-name MYLAB.com
    !
    !
    !
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface FastEthernet0/1
     switchport access vlan 10
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/2
     switchport access vlan 10
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/3
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/4
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/5
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/6
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/7
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/8
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/9
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/10
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/11
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/12
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/13
     switchport access vlan 20
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/14
     switchport access vlan 20
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/15
     switchport access vlan 20
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/16
     switchport access vlan 20
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/17
     switchport access vlan 30
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/18
     switchport access vlan 30
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/19
     switchport access vlan 40
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/20
     switchport access vlan 40
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/21
     switchport access vlan 50
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/22
     switchport access vlan 50
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/23
     switchport access vlan 50
     switchport mode access
     switchport nonegotiate
    !
    interface FastEthernet0/24
     switchport access vlan 50
     switchport mode access
     switchport nonegotiate
    !
    interface GigabitEthernet0/1
     switchport mode trunk
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
     ip address 192.168.1.5 255.255.255.0
     no ip route-cache
    !
    ip default-gateway 192.168.1.10
    ip http server
    !
    control-plane
    !
    !
    line con 0
    line vty 0 4
     login local
     transport input telnet
    line vty 5 15
     login local
     transport input telnet
    !
    end
7
  • Does a machine in a given VLAN ping its default gateway (the IP address of the router for its vlan)?
    – JFL
    Nov 26, 2021 at 14:08
  • 4
    dot1q tunneling ethertype 0x9100 is for QinQ, it doesn't apply to your case, try to remove it.
    – JFL
    Nov 26, 2021 at 14:14
  • 1
    You need to explictly create the VLANs at least on the switch.
    – Zac67
    Nov 26, 2021 at 14:25
  • ty.. I will remove that config. no pings. as IP are not being assigned on the non-default vlans Nov 26, 2021 at 14:25
  • 1
    You are only using NAT on the VLAN 1 interface of the router. If you want to access the Internet via FastEthernet4 from all the VLANs, then you need ip nat inside on those VLAN interfaces, too. That tells the router to translate for those interfaces.
    – Ron Maupin
    Nov 26, 2021 at 15:37

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.