2

I've been working on a this network where I have 2 routers, Main router and failover router. both routers are connected to the main switch via fa0/0 which is divided into 3 sub interfaces, fa0/0.10, fa0/0.20, and fa0/0.30. The main switch is then connected to 3 other switches acting as "departments" in my imaginary company. the switches have 4 vlans in total, vlan 10 for IT, vlan 20 for Marketing, vlan 30 for Accounting, and vlan 99 which is a management vlan. Taking a look up top you'll see a placeholder pc acting as my "internet", which is also connected to both routers via a switch. The same is true for the server right below it. All interfaces have HSRP enabled on them and it seems to switch the active router properly whenever I kill a link. But, even though it switches properly I cant ping the server nor the internet PC.

Here's the network diagram:

Network diagram

and here are the running configurations for all routers and switches:

Main Router:

Current configuration : 1731 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017580O-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.2 255.255.255.0
 ip helper-address 192.168.0.2
 standby 1 ip 192.168.10.1
 standby 1 priority 120
 standby 1 preempt
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.2 255.255.255.0
 ip helper-address 192.168.0.2
 standby 2 ip 192.168.20.1
 standby 2 priority 120
 standby 2 preempt
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.2 255.255.255.0
 ip helper-address 192.168.0.2
 standby 3 ip 192.168.30.1
 standby 3 priority 120
 standby 3 preempt
!
interface FastEthernet0/0.99
 encapsulation dot1Q 99
 ip address 192.168.99.10 255.255.255.0
 standby 4 ip 192.168.99.1
 standby 4 priority 120
 standby 4 preempt
!
interface FastEthernet0/1
 ip address 192.168.0.3 255.255.255.248
 duplex auto
 speed auto
 standby 5 ip 192.168.0.1
 standby 5 priority 120
 standby 5 preempt
!
interface FastEthernet1/0
 ip address 172.16.1.2 255.255.0.0
 duplex auto
 speed auto
 standby 6 ip 172.16.1.1
 standby 6 priority 120
 standby 6 preempt
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
logging trap debugging
logging 192.168.0.2
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
ntp server 192.168.0.2
!
end

Failover router:

Current configuration : 1473 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX10179AZO-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.3 255.255.255.0
 ip helper-address 192.168.0.2
 standby 1 ip 192.168.10.1
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.3 255.255.255.0
 ip helper-address 192.168.0.2
 standby 2 ip 192.168.20.1
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.3 255.255.255.0
 ip helper-address 192.168.0.2
 standby 3 ip 192.168.30.1
!
interface FastEthernet0/0.99
 encapsulation dot1Q 99
 ip address 192.168.99.11 255.255.255.0
 standby 4 ip 192.168.99.1
!
interface FastEthernet0/1
 ip address 192.168.0.4 255.255.255.248
 duplex auto
 speed auto
 standby 5 ip 192.168.0.1
!
interface FastEthernet1/0
 ip address 172.16.1.3 255.255.0.0
 duplex auto
 speed auto
 standby 6 ip 172.16.1.1
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
logging trap debugging
logging 192.168.0.2
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
ntp server 192.168.0.2
!
end

Main switch:

Current configuration : 1314 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.2 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Marketing switch:

Current configuration : 2419 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.3 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

IT switch:

Current configuration : 2368 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.4 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Accounting switch:

Current configuration : 2368 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 30
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.5 255.255.255.0
!
ip default-gateway 192.168.99.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

The problem here is that the main Router works as intended, whilst the failover router fails to provide a connection even though it switches state to active. I double checked the connections in the main switch and all 5 interfaces connected to the switches and routers are set as trunks (which I was really hoping it would be that).

All input is appreciated and I look forward to hearing your responses. I`m quiet new to this website so feel free to drop a comment letting me know how this question could be better formulated/formatted. Cheers.

EDIT: I'm trying to ping the internet from the PCs in the departments. If i try to ping from Marketing for example, 192.168.30.1 responds: "destination host unreachable". All departments also lose connection to the server.

EDIT2: I've managed to isolate the problem. I have 6 HSRP groups, group 1, 2, 3, and 4, are listening for 192.168.10.1, 192.168.20.1, 192.168.30.1, and 192.168.99.1 respectively. group 5 is listening for 192.168.0.1 (the server network), and group 6 is listening for 172.16.1.1 (the internet). when I kill the link between the main router and the main switch, Groups 1-4 activate in the failover router, but not group 5 and 6. This is why the PCs are unable to ping the internet and the server. any suggestions on how I can fix this issue?

6
  • When the primary router goes down and the secondary takes over, does your issue happen for all networks it has interfaces for or just specific ones?
    – Jesse P.
    Dec 23, 2021 at 1:43
  • I cant ping the server nor the internet PC - from where?
    – Zac67
    Dec 23, 2021 at 7:44
  • I'm trying to ping the internet from one of the PCs in the marketing/IT/Accounting departments. They also lost connection with the server. Basically all interfaces seem to be down. Dec 23, 2021 at 10:08
  • 2
    The first thing to check is that each host is able to ping its default gateway. Then you traceroute towards your destination and check where the route breaks.
    – Zac67
    Dec 23, 2021 at 10:20
  • 1
    Run show vlan on the switches - as it seems, you haven't really created the VLANs. Also, try to ping the routers' dedicated IP addresses.
    – Zac67
    Dec 23, 2021 at 10:50

1 Answer 1

4

After isolating the issue to group 5 and group 6 not activating on the failover router by tracerouting towards my destination as the comments suggested. I managed to solve it by tracking interface fa0/0 on group 5 and 6 and changing their priority to 105. When interface fa0/0 dies, the main router's priority is decremented and group 5 and 6 in the failover router are activated. I've also added preempt to group 5 and 6 on the failover router to make sure it switches to active when the main router's priority decreases. I've tested this and confirmed that everything is working properly now. Thanks for your input.

1
  • Please accept your answer so that the question does not keep popping up forever, looking for an answer.
    – Ron Maupin
    Dec 25, 2021 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.