0

Im trying to make a web cluster (HTTP and FTP) with 3 linux machines where the packets are balanced through NAT and im using Bridge interfaces and HSRP, because im using 2 routers(using c3660 image) to make all highly available. I am using the microxp machines to test the connection. This is my configuration. this is my configuration

The problem is when i turn on only 1 linux it works fine but when i turn more than 1 and try to access the website it doesnt work and the R5 router gets slower and after sometime shows errors of sysmalloc as you can see in the image below enter image description here

I thought it was something to do with stp configuration but i think its all correct but i think its something to do with a network loop In the linux machines i have configured bridge with stp on too. Here is my routers configurations:

R5 configuration:

    !

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
bridge irb
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet5/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial6/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface BVI1
 ip address 172.11.255.2 255.255.0.0
 ip nat outside
 ip virtual-reassembly
 standby 10 ip 172.11.255.1
 standby 10 preempt
!
interface BVI2
 ip address 192.168.11.253 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 standby 5 ip 192.168.11.254
 standby 5 preempt
 standby 5 name HSRP2
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
ip nat Stateful id 1
  redundancy HSRP2
   mapping-id 100
   protocol   udp
ip nat pool cluster 192.168.11.1 192.168.11.3 prefix-length 24 type rotary
ip nat inside destination list CLUSTERCONNECTIONS pool cluster mapping-id 100
!
!
ip access-list extended CLUSTERCONNECTIONS
 permit tcp any host 172.11.255.1 eq www
no cdp log mismatch duplex
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 configuration:

!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
bridge irb
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet5/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial6/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface BVI1
 ip address 172.11.255.3 255.255.0.0
 ip nat outside
 ip virtual-reassembly
 standby 10 ip 172.11.255.1
 standby 10 priority 90
 standby 10 preempt
!
interface BVI2
 ip address 192.168.11.252 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 standby 5 ip 192.168.11.254
 standby 5 priority 90
 standby 5 preempt
 standby 5 name HSRP2
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
ip nat Stateful id 1
  redundancy HSRP2
   mapping-id 100
   protocol   udp
ip nat pool cluster 192.168.11.1 192.168.11.3 prefix-length 24 type rotary
ip nat inside destination list CLUSTERCONNECTIONS pool cluster mapping-id 100
!
!
ip access-list extended CLUSTERCONNECTIONS
 permit tcp any host 172.11.255.1 eq www
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
2
  • 1
    Again, please never, ever use an image for text as you did for the error image. Simply copy the text, paste it into your post, and use the Preformatted-text option (`{}) on it.
    – Ron Maupin
    Jan 12 at 21:17
  • Sounds like you need to allocate more memory to the crouter instances
    – Ron Trunk
    Jan 12 at 22:36
0

I found the solution. My UbuntuServers had the same mac address which was causing a broadcast storm. Just needed to change the mac address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.