2

I'm very new to all of this but I am trying to create a network topology as practice that uses three etherchannels across three switches and then rely on STP to block one. So far it was working well. However, when I look at the spanning tree, I see that whilst the ether channel says it is blocking, the ports I am using (which as far as I am aware shouldn't be showing in the spanning tree) are showing up and saying they are forwarding. What is the issue here as I have spent hours googling this and can't find a solution.

Also I don't understand why I have VLAN 0020 showing as well as VLAN 0001 I do have a plan 20 setup if that is the case but could you also explain this as well. Any help will be a life saver.

P01 should contain G0/1 & G0/2

p02 should contain Fa0/23 & fa0/24

    Switch#show spanning-tree 
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0000.0C7D.2383
             Cost        3
             Port        27(Port-channel1)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0001.C7A9.D229
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Po2              Altn BLK 9         128.28   Shr
Po1              Root FWD 3         128.27   Shr
Fa0/1            Desg FWD 19        128.1    P2p

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    32788
             Address     0000.0C7D.2383
             Cost        3
             Port        27(Port-channel1)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     0001.C7A9.D229
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/3            Desg FWD 19        128.3    P2p
Po2              Altn BLK 9         128.28   Shr
Po1              Root FWD 3         128.27   Shr

Switch#
Switch#
Switch#show eth
Switch#show etherchannel su
Switch#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SU)           LACP   Gig0/1(P) Gig0/2(P) 
2      Po2(SU)           LACP   Fa0/23(P) Fa0/24(P) 
Switch#

My switch configurations are as follows

Switch 0:

Switch#show running-config 
Building configuration...

Current configuration : 1413 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
 switchport mode trunk
!
interface Port-channel2
 switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 20
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport mode trunk
 channel-group 2 mode active
!
interface FastEthernet0/24
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet0/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet0/2
 switchport mode trunk
 channel-group 1 mode active
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch 1:

Switch#show running-config 
Building configuration...

Current configuration : 1413 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel2
 switchport mode trunk
!
interface Port-channel3
 switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 20
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport mode trunk
 channel-group 2 mode active
!
interface FastEthernet0/24
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet0/1
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet0/2
 switchport mode trunk
 channel-group 3 mode active
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch 2:

Switch#show running-config 
Building configuration...

Current configuration : 929 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
 switchport mode trunk
!
interface Port-channel3
 switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet1/1
!
interface FastEthernet2/1
!
interface FastEthernet3/1
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface GigabitEthernet6/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet7/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet8/1
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet9/1
 switchport mode trunk
 channel-group 3 mode active
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


Switch#
Switch#

My network topology looks as the following

enter image description here

6
  • Please edit you question to include the switch configurations. We cannot guess about that.
    – Ron Maupin
    Jan 19, 2022 at 23:44
  • Also, never use an image for the text. Simply copy the text, paste it in, and use the Preformatted-text feature ({}).
    – Ron Maupin
    Jan 19, 2022 at 23:45
  • @RonMaupin Please see changes I have made to the question
    – James
    Jan 20, 2022 at 0:19
  • 1
    You are not placing any VLAN restrictions on your trunks, so all VLANs will be trunked.
    – Ron Maupin
    Jan 20, 2022 at 0:23
  • 1
    The access interface will only have the VLAN you assign for it. You must also create the VLAN in the VLAN database for things to work correctly With VTP, you can just create it on a VTP server and it will be automatically sent to other VTP switch databases via trunks, or you create it on every switch without VTP.
    – Ron Maupin
    Jan 20, 2022 at 0:33

1 Answer 1

0

when I look at the spanning tree, I see that whilst the ether channel says it is blocking, the ports I am using (which as far as I am aware shouldn't be showing in the spanning tree) are showing up and saying they are forwarding.

That is entirely normal. In a spanning tree, all physical links remain linked. They need to do so since the still need to send BPDUs (on designated ports) and receive BPDUs. Blocked ports (or channelgroups) simply don't forward normal frames.

The forwarding status of interfaces aggregated with EtherChannel or LAG is irrelevant. The channelgroup's status is.

why I have VLAN 0020 showing as well as VLAN 0001

You have configured VLAN 20 for access on two switches. Since you're just using switchport mode trunk, all VLANs are trunked across.

You should always explicitly create VLANs by using VLAN x or even better VLAN x name whatevermakessense, otherwise they might not be created automatically on some devices.

Note that spanning-tree mode pvst sets the protocol to RPVST+ mode that creates an independent spanning tree for each VLAN. That mode is Cisco proprietary and only supported by a few other vendors.

The standard IEEE protocols are RSTP and MSTP. While RSTP is completely VLAN-agnostic (and may break a network with incomplete VLAN distribution), MSTP allows you to group VLANs into multiple ST instances with an independent spanning tree each.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.