0

I am trying to create this routing but getting some issues(or not having the routing).

Scenario: simple router: 192.168.1.254 (with DHCP server for all network that is providing wifi and internet to the network).

Internal network: 192.168.1.0/24

HPE 2848 Procurve: 192.168.1.250

Now I have some servers inside the network that uses 192.168.10.0(vlan 33) and 192.168.25.0(vlan 25) Those subnets are configured on some ports of the Switch. All works ok as long I test inside the subnets/vlans. There are untagged.

But I would like that the subnet 192.168.1.0 could reach those 2 subnets.

I tried to create a routing in the HP with "ip route 192.168.10.0 255.255.255.0 192.168.1.254" And also in the simple router created 3 routes:

192.168.1.0  255.255.255.0 192.168.1.254
192.168.10.2 255.255.255.0 192.168.1.254
192.168.25.2 255.255.255.0 192.168.1.254

The goal is not to have internet using those vlans, but only to be able to connect between those subnets.

But is not working. So what I am missing here? Is this the right way to route these subnets/vlans?

UPDATE: reset all HP Procurve configuration. Problem with connecting Router / Switch fixed, a cable was doing a loop.

Changed Switch IP to 192.168.1.253 and using now vlan 10 and 25.

This is the configuration now

**ProCurve Switch 2848# show run**

Running configuration:

; J4904A Configuration Editor; Created on release #I.10.107
hostname "ProCurve Switch 2848"
ip routing
snmp-server community "public" Unrestricted

vlan 1
   name "Maintenance"
   untagged 1-6,8-12,14-17,19-32,35-38,40,43-48
   ip address 192.168.1.253 255.255.255.0
   no untagged 7,13,18,33-34,39,41-42
   exit

vlan 10
   name "VLAN10"
   untagged 7,18,34,42
   ip address 192.168.10.253 255.255.255.0
   jumbo
   exit

vlan 25
   name "VLAN25"
   untagged 13,33,39,41
   ip address 192.168.25.253 255.255.255.0
   jumbo
   exit
ip route 0.0.0.0 0.0.0.0 192.168.1.254
spanning-tree
ip ssh
password manager
ProCurve Switch 2848# sho ip route
                                                                                                                               IP Route Entries
  Destination        Gateway         VLAN Type      Sub-Type   Metric     Dist.
  ------------------ --------------- ---- --------- ---------- ---------- -----
  0.0.0.0/0          192.168.1.254   1    static               1          1
  127.0.0.0/8        reject               static               0          250  
  127.0.0.1/32       lo0                  connected            0          0  
  192.168.1.0/24     Maintenance     1    connected            0          0   
  192.168.10.0/24    VLAN10          10   connected            0          0   
  192.168.25.0/24    VLAN25          25   connected            0          0

ProCurve Switch 2848# show IP

 Internet (IP) Service  
  IP Routing : Enabled
 
  Default TTL     : 64
  Arp Age         : 20
  VLAN         | IP Config  IP Address      Subnet Mask     Proxy ARP 
  ------------ + ---------- --------------- --------------- ---------   
  Maintenance  | Manual     192.168.1.253   255.255.255.0   No
  VLAN10       | Manual     192.168.10.253  255.255.255.0   No
  VLAN25       | Manual     192.168.25.253  255.255.255.0   No

On the Router side I disable the route: 192.168.0.0 255.255.255.254 gateway 192.168.1.253

3
  • You'll need to add an IP address to the 2848 on all VLANs, enable routing (ip routing) and then add routes for the remote subnets on the Fritzbox - however, home networking and consumer-grade hardware are explicitly off-topic here, see the help center. You might want to try on Super User.
    – Zac67
    Commented Feb 11, 2022 at 6:47
  • dont understand why is off-topic and why this is mark as home networking. Because using a Fritzbox? this is HP Procurve 2848 4x HP Dl360 G9 servers ESXi vSphere 7 and a QNAP with 40Tb. If this is home networking, I would like to have one. But ok, I will open in the other area.
    – NoWay
    Commented Feb 11, 2022 at 6:58
  • The AVM Fritzbox is a consumer-grade product, making it off-topic here. Also, the 2800 series is quite ancient (EoS 2009), so I assumed a home network. If you leave the Fritzbox out of your question and it's about an on-topic business network, then we could reopen it. I have edited the question accordingly, please add the 2848's config (using the editor's { } function for readability), so we can see what's wrong.
    – Zac67
    Commented Feb 11, 2022 at 7:31

2 Answers 2

0

Make sure you've added IP addresses to the additional VLANs on the switch, these are used as default gateway for the attached end nodes, e.g.:

vlan 33 ip address 192.168.10.253/24
vlan 25 ip address 192.168.25.253/24

Add a default route to the switch - there's no need to add other routes if all networks are attached to the switch:

ip route 0.0.0.0/0 192.168.1.254

Turn on routing on the switch:

ip routing

You've already added the subnets behind the switch to your router (you need to point them to the L3 switch though). Instead of adding each subnet seperately you could just use a summary route

192.168.0.0/16 via 192.168.1.253

unless there are other routers for the internal network.

Don't forget to change the 192.168.1.0/24 nodes' default gateway to 192.168.1.253 (all nodes but the L3 switch). Alternatively, you could leave the router as default gateway and add explicit routes for 192.168.25.0/24 and 192.168.33.0/24 (or the summary 192.168.0.0/16) via 192.168.1.253 - just like on the router).

Now all VLANs should be routed in between and towards the Internet. To prevent the latter you could use an ACL on the appropriate ports (I think the 2848 doesn't support VLAN ACLs yet), something along:

ip access-list extended LANonly
   1000 permit ip 192.168.0.0/16 192.168.0.0/16
   1010 permit ip 192.168.1.0/24 any          
exit
interface 25 ip access-group LANonly in

(There's an implicit deny ip any any at the end of each ACL.)

DHCP won't work with your router for the subnets behind the L3 switch. The router would need to support VLANs (with direct subnet attachment) or DHCP relay via helper configuration on the switch.

13
  • That is what I did before. But was using instead 192.168.x.2 for both vlans. IP routing I also enabled. So if I understand, is: vlan 33 ip address 192.168.10.250 vlan 25 ip address 192.168.25.250 ip route 0.0.0.0/0 192.168.1.254 IP routing (already enabled) and on the router create a routing 192.168.0.0/16 gateway 192.168.1.250 I still have in the router the routing: 192.168.1.0/24 gateway 192.168.1.254. Do I need to delete? If yes, a question, will this not impact the DHCP and the other clients on the subnet 192.168.1.x
    – NoWay
    Commented Feb 11, 2022 at 12:58
  • Possibly the only problem with your setup was the routes on the router pointing to the router itself as gateway, which needs to the L3 switch instead. 192.168.1.0/24 is directly attached, so it requires no explicit route at all.
    – Zac67
    Commented Feb 11, 2022 at 13:16
  • I reset HP Switch configuration and start over. This is the new configuration. ProCurve Switch 2848# show ip Internet (IP) Service IP Routing : Enabled Default TTL : 64 Arp Age : 20 VLAN | IP Config IP Address Subnet Mask Proxy ARP ------------ + ---------- --------------- --------------- --------- DEFAULT_VLAN | Manual 192.168.1.250 255.255.255.0 Yes VLAN25 | Manual 192.168.25.250 255.255.255.0 No VLAN33 | Manual 192.168.10.250 255.255.255.0 No
    – NoWay
    Commented Feb 11, 2022 at 15:11
  • ProCurve Switch 2848# show ip route IP Route Entries Destination Gateway VLAN Type Sub-Type Metric Dist. ------------------ --------------- ---- --------- ---------- ---------- ----- 0.0.0.0/0 192.168.1.254 1 static 1 1 127.0.0.0/8 reject static 0 250 127.0.0.1/32 lo0 connected 0 0 192.168.1.0/24 DEFAULT_VLAN 1 connected 0 0
    – NoWay
    Commented Feb 11, 2022 at 15:14
  • And in the router I add the route: 0.0.0.0 255.255.255.254 gateway 192.168.1.250 But when I connect a cable from Switch to router, router lost connection and can't ping the router itself that is the 192.168.1.254
    – NoWay
    Commented Feb 11, 2022 at 15:14
1

You have to create two vlan interfaces on the HPE for vlan 33 and vlan 25 with ip addresses belonging to those vlans, say 192.168.10.254 and 192.168.25.254.

Hosts on those vlans must have their default gateway 192.168.10.254 and 192.168.25.254 respectively.

On HPE add a default route to 192.168.1.254

On the Internet Router add routes for 192.168.10.0/24 and 192.168.25.0/24 pointing to 192.168.1.250

I don't know for HPE, but probably you have to enable ip routing if it's not enabled by default.

UPDATE

If you want hosts on 192.168.1.0/24 to be able to reach hosts on vlan33 and vlan25, make sure that the default gateway for hosts on 192.168.1.0/24 is 192.168.1.253.

Now you'll have reachability between vlans and only vlan1 can get to the Internet as only 192.168.1.0/24 is NATed by the router

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.