0

I have cisco SG220 series switches with 50 Port available for use before unknown incident happened. After the unknown incident happened 24 port consist of Gi1 - Gi12 and Gi25 - Gi36 can't be used.

enter image description here

when i attach a UTP cable with the other side connected to laptop to Port Gi1 Cisco Switch, the Port Gi1 LED not blinking. and when i type no shutdown in config-if mode the console return Port gi1: Invalid port id. But when the UTP cable is attached to Port Gi13 - 24 or Gi37 - Gi48 it's work normally. I'm already reset the switch to solve the problem but it's not work.

I want to diagnostic, troubleshoot, or another detailed information how to solve this. I'm already search in google with Cisco Switch SG220-50: Invalid port id keyword but that's not give me any clue.

Here is the console output:

Switch97A68B#conf t
Switch97A68B(config)#int gi 1
Switch97A68B(config-if)#no shutdown
Port gi1: Invalid port id
Switch97A68B(config-if)#end
Switch97A68B#show int gi1
GigabitEthernet1 is down
  Hardware is Gigabit Ethernet
  Auto-duplex, Auto-speed, media type is Copper
  flow-control is off
  back-pressure is enabled
     0 packets input, 0 bytes, 0 throttles
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underrun
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 PAUSE output
Switch97A68B#show interfaces status gi1
Port  Name                 Status      Vlan  Duplex  Speed    Type
gi1                        notconnect  1     auto    auto     Copper

Port Time Range                       Status
---- -------------------------------- --------
gi1

Update 1

Switch97A68B#show run                                                                                                                                                                                      [168/1978]
config-file-header
Switch97A68B
v1.1.3.1
CLI v1.0
@
!
!
!
!
username "cisco" secret encrypted xxx=
!
!
!
vlan 17
 name "vlan17-SERVER_AP"
vlan 32
 name "vlan32-FINANCE"
vlan 34
 name "vlan34-IT"
vlan 35
 name "vlan35-PLANT"
vlan 36
 name "vlan36-CS"
voice vlan oui-table add 00:E0:BB 3COM
voice vlan oui-table add 00:03:6B Cisco
voice vlan oui-table add 00:E0:75 Veritel
voice vlan oui-table add 00:D0:1E Pingtel
voice vlan oui-table add 00:01:E3 Siemens
voice vlan oui-table add 00:60:B9 NEC/Philips
voice vlan oui-table add 00:0F:E2 H3C
voice vlan oui-table add 00:09:6E Avaya
!
!
!
!
spanning-tree mst configuration
 name "D4:AD:71:97:A6:8B"
!
!
!
!
!
!
!
!
!
!
ip ssh server
!
!
!
!
!
!
!
!
!
interface gi1                                                                                                                                                                                             
 no eee enable
 switchport mode access
!
interface gi2
 no eee enable
!
interface gi3
 no eee enable
!
interface gi4
 no eee enable
!
interface gi5
 no eee enable
!
interface gi6
 no eee enable
!
interface gi7
 no eee enable
!
interface gi8
 no eee enable
!
interface gi9
 no eee enable
!
interface gi10
 no eee enable
!
interface gi11
 no eee enable
!
interface gi12
 no eee enable
!
interface gi13
!
interface gi14
 switchport mode access
 switchport access vlan 36
!
interface gi15
 switchport mode access
 switchport access vlan 32
!
interface gi16
 switchport mode access
 switchport access vlan 32
!
interface gi17
 switchport mode access
 switchport access vlan 32
!
interface gi18
!
interface gi19
 switchport mode access                                                                                                                                                                                    
 switchport access vlan 34
!
interface gi20
!
interface gi21
 switchport mode access
 switchport access vlan 35
!
interface gi22
!
interface gi23
 switchport mode access
 switchport access vlan 35
!
interface gi24
!
interface gi25
 no eee enable
!
interface gi26
 no eee enable
!
interface gi27
 no eee enable
!
interface gi28
 no eee enable
!
interface gi29
 no eee enable
!
interface gi30
 no eee enable
!
interface gi31
 no eee enable
!
interface gi32
 no eee enable
!
interface gi33
 no eee enable
!
interface gi34
 no eee enable
!
interface gi35
 no eee enable
!
interface gi36
 no eee enable
!
interface gi37
!
interface gi38
!
interface gi39
!
interface gi40
 switchport mode access
 switchport access vlan 32
!
interface gi41
 switchport mode access
 switchport access vlan 32
!
interface gi42
 switchport mode access
 switchport access vlan 32
!
interface gi43
!
interface gi44
 switchport mode access
 switchport access vlan 32
!
interface gi45
 switchport mode access
 switchport access vlan 35
!
interface gi46
 switchport mode access
 switchport access vlan 35
!
interface gi47
 switchport mode access
 switchport access vlan 36
!
interface gi48
 switchport mode access
 switchport access vlan 17
!
interface gi49
 switchport trunk allowed vlan add 2-200
!
interface gi50
!
!
!

show logging for logging output

5
  • 1
    Please add the full config (show run) to your question - if you've configured ports into a port channel, direct configuration may be limited.
    – Zac67
    Feb 11, 2022 at 9:44
  • Try to view the logging (show logging) Feb 11, 2022 at 11:03
  • Watch startup (boot) messages. Something has killed two of the internal SoC's. Most of the time, it's a bad capacitor, but I have a (nortel) switch with a bad clock crystal. I have a very old netgear switch with dozens of bad caps; it can't see any of the switch SoC's. If the device is still under warranty, contact Cisco.
    – Ricky
    Feb 11, 2022 at 19:44
  • i have updated my question. thanks for helping me solve this problem
    – Abu Dawud
    Feb 12, 2022 at 1:34
  • @Ricky how to watch that message in Cisco SG220-50 ?
    – Abu Dawud
    Feb 12, 2022 at 1:36

1 Answer 1

1

It's a hardware failure. I can't prove it but the last choice is Product Returns & Replacements (RMA). Here's the link to my discussion on cisco community.

https://community.cisco.com/t5/switching/cisco-switch-sg220-50-invalid-port-id/m-p/4550315/thread-id/518263#M518385

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.