0

Current Network Setup

I have three Cisco 2960 switches. Each switch linked to a lab of 12 windows 10 computers. All three switches are in the same cabinet.

1st switch connected to 2nd switch using the fiber module SFP 2nd switch connected to 3rd switch using the fiber module SFP

I have also one windows 2016 server that has a shared folder but only connected to the first switch.

Current switch configuration

    Switch#show running-config
Building configuration...

Current configuration : 1266 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 5 15
!
end

I used the web based configuration interface to only assign the "smartports" to indicate what ports used for the other two switches. I don't know if there is more configuration needed to be done.

Current server configuration

There's only shared folder but currently linked to one switch and only seen through the computers that are linked to that switch. No DHCP service on the server and all computers are assigned static IP addresses

Configuration of the computers in the network

All computers are assigned static IP address. All computers are assigned same subnet mask 255.255.255.0 Default gateway : empty DNS Servers: empty

There is no router, no internet, just local network.

What I need is to link all switches together so that all computers in all three labs can see each other and for the shared folder in the sever to be seen by all computers.

I tried so far to use two fiber cables to link the first switch to the two switches. I also tried to link 1st switch to 2nd switch, then 2nd switch to 3rd switch using fiber cables plugged to the fiber ports on the switch. Also tried to use UTP straight cable to connect the switches. None of these methods worked.

9
  • Please edit the question to iclude the switch configurations, and be sure to explain which interfaces are connected to which switches. Also, remember that you need to use the same network, or you will need to enable routing and properly set the gateway on the hosts.
    – Ron Maupin
    Feb 13, 2022 at 1:53
  • "used the web based configuration interface to only assign the "smartports" to indicate what ports used for the other two switches. I don't know if there is more configuration needed to be done." Yes, just use the CLI to do the show running-config command, copy the results, and paste the into the question . Use the Preformatted-text option ({}). We cannot simply guess at where you may have gone wrong in the configuration.
    – Ron Maupin
    Feb 13, 2022 at 2:13
  • None of these methods worked isn't a proper problem description. Do the link LEDs light up? Can you ping across the switches by IP address? Are all computers even part of the same /24 subnet?
    – Zac67
    Feb 15, 2022 at 5:58
  • Connect GigabitEthernet0/1 of the first switch to GigabitEthernet0/1 of the second then connect GigabitEthernet0/2 of the first switch to GigabitEthernet0/1. then in the interface configuration of switch 1 for gi0/1 and g0/2: switch port mode trunk and the same for the other switches Feb 15, 2022 at 6:24
  • @RonMaupin Thank you @Zac67 Thank you. Both linked fiber optics cables LEDs light up yes. I can bing the computers within the switch but not between computers that are on different switches. @SoulimaneMammar I did that but I didn't try the switchport mode trunk command if that's what you mean.
    – Sam
    Feb 16, 2022 at 9:54

2 Answers 2

2

Set the switches all to default configuration, connect 1 cable between each switch (requiring a total of 2 cables to connect 3 switches). Do not create a loop between the switches, a simple cable of your preferred type, cat5 or fiber, from one switch to the next will suffice.

Now you have the switches connected to each other. That is all that is required with Cisco switches of that type. Without further configuration they will work just fine, as would any unmanaged switch.

From here, you only need to configure the Windows operating system correctly on each workstation and server to have them all access a shared folder on one of the servers. For that, see any of a number of helpful guides on many websites such as this:

https://www.tenforums.com/tutorials/111783-share-files-folders-over-network-windows-10-a.html

Or ask the help of anyone in your organization who is familiar with Windows computer administration.

To make things easier, it is helpful for the computers to have internet access and be configured via a DHCP server. It saves time and effort and Windows is designed to work in that kind of environment so it makes it all much easier.

Basically, it should all just work automatically if you don't mess with things and interfere with how it all comes with its initial configuration.

If you want to make it all work really well, you can look into Windows Active Directory Domain services but that is an additional topic you can read about separately. It sounds to me you are trying to do something like setting up a lab for an organization or business so you should probably have someone available to you who has experience with this and you will want to enlist their help, lest you cause problems for them inadvertently.

0

With that basic switch configuration you've created an entirely 'flat' network - all ports belong to the same, default VLAN = layer-2 segment.

In order for the connected hosts to 'see' each other on layer 2/Ethernet, all you have to do is to connect the switches with each other. Just chain them - if you form a ring, RPVST+ is active and kicks in to prevent a bridge loop by blocking one of the connections. Fiber or twisted pair doesn't matter, but when a cable is plugged on both sides, the link LEDs need to light up.

If the LEDs stay dark the cable might not be correct - fiber patches are generally crossed: the strand that plugs into the left-hand side of the jack needs to go the right-hand side on the other switch and vice versa. Usually there are colored rings on the fiber sleeve.

Twisted-pair copper cables are usually connected straight through (1:1 pinout). The 2960 series supports Auto MDI-X, so using a straight or a crossover cable doesn't matter.

All computers are assigned static IP address. All computers are assigned same subnet mask 255.255.255.0 Default gateway : empty DNS Servers: empty

That should do. Note that for the hosts to see each other on layer 3/IP, all hosts need to share the same subnet, e.g. 192.168.100.0/24. If they don't, an additional router is required (the 2960s could be used to route between different VLANs as well). Also note that for host names to work either proper DNS or some kind of broadcast resolution is required (mDNS) but that and host configurations are explicitly off-topic here.

2
  • Thank you. Should all switches have the same hostname and IP Address? since I need them to be one network?
    – Sam
    Feb 16, 2022 at 15:29
  • For switching purposes, no host name or IP address is required. Since those are managed switches, you need to assign a unique host name and IP address to each of them.
    – Zac67
    Jul 15, 2022 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.