7

I'm trying to back up a Cisco ISE server (version 1.2.0.899 patch 4) via sftp.

I configuered a repo via the web gui. I added the hostkey (for the backup server) via the command line. I make sure the path exsites on the backup server. I then start a backup via the web gui using the repo that I just set up. The back up jumps to %20, %45, %60, and then %100. I then see the status saying the backup was a success.

The problem is that no backup actually happens. I don't see the files in the web gui under "History for Repository". I also don't see the backups on the backup server.

Via the ISE console I use the command sh repository "rep name" I just get a message saying that it's empty.

If I run the command show backup status I get the following:

%% Configuration backup status
%% ----------------------------
%      backup name: test5
%       repository: test
%       start date: Thu May 08 
%        scheduled: no
%   triggered from: Admin web UI
%             host: ISESERVER.xxx.yyy
%           status: backup test5-CFG-140508-1317.tar.gpg to repository test: success

%% Operation backup status
%% ------------------------
%  No data found. Try 'show backup history' or ISE operation audit report

On the back up server I'm not seeing a connection from the ISE server even attempted.

Any ideas on how to move forward with this?

Edit:

I checked the backup servers SSH logs and it looks like the ISE service account is able to login but then the session is immediately closed.

May 12 10:51:18 BACKUPSERVER sshd[5190]: Accepted password for SERVICE_ACCOUNT from 1.1.1.1 port 47558 ssh2
May 12 10:51:18 BACKUPSERVER sshd[5190]: pam_unix(sshd:session): session opened for user SERVICE_ACCOUNT by (uid=0)
May 12 10:51:18 BACKUPSERVER sshd[5190]: pam_unix(sshd:session): session closed for user SERVICE_ACCOUNT
  • Have you checked the sh respository "test" – HAL May 8 '14 at 21:00
  • Yes, You might have missed it but I said that when I run that command i get a message saying that it's empty. – evolvd May 8 '14 at 22:10
4

The problem ended up being a permission issue on the backup server. This didn't seem to be a problem since ISE was able to read the backup folder. I also thought this was an issue on ISE's side since it was reporting the backup successful when it wasn't. It seems that ISE reports the backup is successful if it can login to the remote server and pool the backup data locally. Even if that data doesn't reach the server it will still show as successful.

The permission issue is that the service account that I used only had read access to the backup location and no write.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.