0

I have a new feed from an ISP, that would be slow to respond to any change requests.

They tagged this drop with a vlan ID of 10, which I happen to already be using on my switches.

I want a brand new vlan (let's say 33) for this.

Is it possible on HP flexfabric to take this feed, strip the 10 and put it in 33 on my side?

This is working (but undesired):

interface T1/0/2
port link-type trunk
port trunk permit vlan 10

I can then put a VirtualMachine in Vlan10 or even assign a VLAN-Interface10 on the switch itself and ping the ISP's gateway.

What I WANT to do is essentially retag anything coming in on vlan 10, as vlan 33 on my side - and vice versa. With loads of reading I tried this:

(Vlan 10 already exists on my side, Vlan 33 is new)

interface Ten-GigabitEthernet1/0/2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 33 10
 vlan mapping 33 translated-vlan 10

or

interface Ten-GigabitEthernet1/0/2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 33 10
 vlan mapping 10 translated-vlan 33

Have also tried inserting both vlan mapping statements.

I've also tried various iterations of a hybrid port and setting 10 as tagged and 33 as untagged & vice-versa.

I feel like I'm missing something silly and driving myself mad.

Is there anyone that could provide some insight?

Edit: more complete configs

vlan 33
 description New VLAN on my side
vlan 10
 description Existing VLAN on my side. ISP's new drop has this tagged the same

==Standard VLAN ATTEMPT== Working!

In this port is the drop from my ISP:

interface Ten-GigabitEthernet1/0/2
 description ISP DROP
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 10

In this port is a trunk with vlan 10:

interface Ten-GigabitEthernet2/0/21
 description VMUPLINK
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 10 200 300 400 601
#

Simple access port:

interface Ten-GigabitEthernet2/0/22
 description Test VLAN10
 port access vlan 10
#

Test Vlan interface in existing VLAN 10

interface Vlan-interface10
 ip address 142.84.55.62 255.255.255.252

I can now ping 142.84.55.61 (IP modified for the internet but it is indeed a /30) from:

  1. The Vlan interface
  2. the access port 2/0/22
  3. a VM in a Port Group assigned vlan id 10

==VLAN MAPPING ATTEMPT== Not working!

In this port is the drop from my ISP:

interface Ten-GigabitEthernet1/0/2
 description ISP DROP
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 33 10
 vlan mapping 10 translated-vlan 33

In this port is a trunk with vlan 33 and a vlan in it:

interface Ten-GigabitEthernet2/0/21
 description VMUPLINK
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 33 200 300 400 601
#

This port is a simple access port in 33

interface Ten-GigabitEthernet2/0/22
 description Test VLAN33
 port access vlan 33
#

Attempted Vlan interface in New VLAN 33

interface Vlan-interface33
 ip address 142.84.55.62 255.255.255.252

I can't ping 142.84.55.61 (IP modified for the internet but it is indeed a /30) from neither:

  1. The Vlan interface
  2. the access port 2/0/22
  3. a VM in a Port Group assigned vlan id 33
13
  • Hybrid-mode port and untagged VLANs won't get you anywhere. The bit with vlan mapping 10 translated-vlan 33 looks about right - where's the problem? Have you checked the MAC table on that port with the desired VLAN? You did configure another port into VLAN 33 as well, didn't you?
    – Zac67
    Mar 8 at 21:21
  • Whether I try a [new] Vlan interface (in what is now 33) or stick a machine into a port designed for 33 - I can no longer ping the same gateway.
    – Sputnikk23
    Mar 8 at 21:24
  • Have you explicitly created both VLANs?
    – Zac67
    Mar 8 at 21:26
  • Yes, or it wouldn't let me add them to the permitted list nor create a vlan interface in it :)
    – Sputnikk23
    Mar 8 at 21:27
  • 1
    Please add the complete configuration to your question and tell us where everything is connected. Also make sure the configured translations show up with display vlan mapping.
    – Zac67
    Mar 8 at 21:31

1 Answer 1

1

I can't see a problem with vlan mapping 10 translated-vlan 33 - that translates an incoming VLID 10 on that port to VLID 33 for internal and further external use, and vice versa.

Troubleshooting steps:

  • make sure the CPE's MAC address shows up in the switch's MAC table in VLAN 33 as well as the pinging/test host
  • if ping fails, check whether ARP works: the CPE's IP address needs to be associated with its MAC address in the local ARP cache of the pinging host
  • if you've got access to the CPE, it should also show an ARP entry for the pinging host
  • if everything fails, connect a switch with tagged VLAN 10 and port mirroring/monitoring in between the 5700 and the CPE - a packet capture should show you exactly what is going on
  • alternatively, you could connect another VLAN-capable device with tagged VLAN 10 and test connectivity

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.