2

In the picture, I have a part of my topology. The concept is that I am trying to configure OSPF in my network. Internet is a nat cloud module. The routers are all iosv routers. ISP 1 has the following commands:

    interface GigabitEthernet0/0 
description Link To Internet 
ip address dhcp 
ip nat outside 
interface GigabitEthernet0/1
ip address 194.10.10.1 255.255.255.0 
ip nat inside 
interface GigabitEthernet0/2 
no ip address 
shutdown 
interface GigabitEthernet0/3 
no ip address 
shutdown 
ip nat inside source list 1 interface GigabitEthernet0/0 overload 
ip route 0.0.0.0 0.0.0.0 194.10.10.2 150 
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp

Router 1 has the following commands:

interface Loopback 0
ip address 1.1.1.1 255.255.255.255
interface GigabitEthernet0/0 
ip address 194.10.10.2 255.255.255.0 
ip nat outside 
interface GigabitEthernet0/1 
ip address 192.168.2.1 255.255.255.0
 ip nat inside 
interface GigabitEthernet0/2 
ip address 192.168.1.1 255.255.255.0 
ip nat inside
interface GigabitEthernet0/3 
ip address 10.10.10.1 255.255.255.0 
ip nat outside 
router ospf 10 
network 192.168.1.0 0.0.0.255 area 0 
network 192.168.2.0 0.0.0.255 area 0
ip nat pool i 193.1.1.1 193.1.1.254 netmask 255.255.255.0 
ip nat inside source list 1 pool 1 overload 
ip route 0.0.0.0 0.0.0.0 194.10.10.1

Router 4 has the following commands:

interface Loopback0 
ip address 4.4.4.4 255.255.255.255
interface GigabitEthernet0/0 
ip address 192.168.5.1 255.255.255.0 
interface GigabitEthernet0/1
ip address 192.168.7.1 255.255.255.0 
interface GigabitEtherneto/2
ip address 192.168.10.2 255.255.255.0 
interface GigabitEthernet0/3 
ip address 192.168.8.1 255.255.255.0 
router ospf 10 
network 192.168.1.0 0.0.0.255 area 0 
network 192.168.2.0 0.0.0.255 area 0 
network 192.168.3.0 0.0.0.255 area 0 
network 192.168.5.0 0.0.0.255 area 0 
network 192.168.7.0 0.0.0.255 area 0 
network 192.168.10.0 0.0.0.255 area 0
network 192.168.11.0 0.0.0.255 area 0 
network 192.168.12.0 0.0.0.255 area 0
ip route 0.0.0.0 0.0.0.0 192.168.10.1 
ip route 0.0.0.0 0.0.0.0 194.10.10.1 
ip route 0.0.0.0 0.0.0.0 192.168.1.1 
ip route 0.0.0.0 0.0.0.0 192.168.5.2 120 
ip route 0.0.0.0 0.0.0.0 192.168.7.2 130

The part of the topology:

enter image description here

ASAV1 has the following commands:

gig 0/0 
nameif outside 
security level 0 
ip address 192.168.1.2/24 
gig 0/1
nameif inside
security level 100
ip address 192.168.10.1/24
router ospf 10
network 192.168.1.0 255.255.255.0 area 0 
network 192.168.2.0 255.255.255.0 area 0 
network 192.168.10.0 255.255.255.0 area 0
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1

So my question is what do I need to add or remove in order to make OSPF work in the first place and make router 4 ping 8.8.8.8? Some commands in the configurations are from the other part of my network. I just made a screenshot of the part of the network that we need in order to fix the issue.

0

1 Answer 1

2

Let us from outside and work to towards inside :

ISP -

Who will need to create an acl for the networks that will be xlate using the below line

ip nat inside source list 1 interface GigabitEthernet0/0 overload

!

!
!
access-list 1 permit 194.10.10.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.20.0 0.0.0.255
!

For connectivity, you will need extend OSPF to the ISP or the appropriate static routes.

I wonder if there is any need for NAT configuration and if there is, you will need to duplicate the config of ISP1.

Router1 configuration should be similar to ISP1 if nat is necessary. ASA1 configuration requires many lines of configuration and added my config below:

interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 192.168.10.2 255.255.255.0 
!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 ip address 192.168.20.1 255.255.255.0 
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network INSIDE
 subnet 192.168.20.0 255.255.255.0
object network OUTSIDE
 subnet 192.168.10.0 255.255.255.0
object network INSIDE_2
access-list outside_in extended permit ip any4 any4 
access-list inside_in extended permit ip any4 any4 
pager lines 23
logging buffered informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 8192
nat (inside,outside) source static INSIDE INSIDE destination static OUTSIDE OUTSIDE
access-group outside_in in interface outside
access-group inside_in in interface inside
router ospf 10
 network 0.0.0.0 0.0.0.0 area 0
 log-adj-changes
!
route outside 0.0.0.0 0.0.0.0 192.168.10.1 1

Router4 config is straightforward and it should form an OSPF adj with ASA1.

2
  • Alright, so first of all I add some access-list rules to the isp configuration and the second step is to put isp to my OSPF? Or is it better to do it with static routes? If I do it with static routes the other devices inside OSPF like router 4 will reach the isp and eventually the internet? In the third step , yes NAT is needed so will it change anything in the configuration? All that before reaching ASAV. Thanks for your time!
    – ECHO
    Commented Mar 12, 2022 at 9:29
  • 1
    Putting all routers in OSPF area 0 will resolve your direct internal connectivity. In order to propagate the default route to external : router ospf 1 default-information originate
    – user702617
    Commented Mar 13, 2022 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.