0

Looking for some help setting up a Dell PowerConnect 2724. 1st time setting one of these up.

The best graphic I could find to explain my setup: enter image description here

My router DHCP is enabled so it will provide IP addresses (I have confirmed that by connecting to simple switch and connecting devices to that switch)

I have created VLAN 101 and 102

For 101, I have Port 1 Tagged and ports 3 & 5 untagged (I have also tried vice versa and all tagged and all untagged I have also configured the ports to allow all, allow tagged, and a mix.)

When I connect a device to port 3 or 5, regardless if I have the port set to auto or I assign a static IP, I can not get anything to connect to the VLAN1 or VLAN2

(I am doing all this with the managed led on)

I am sure I missing something simple. Anyone see what I am doing wrong? Thank You.

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Nov 19, 2022 at 23:05

2 Answers 2

0

The Dell PowerConnect 2724 has a really poor way of settings VLAN.

To set up access port correctly you have to:

  • set the chosen VLAN as untagged on the port, in the page "VLAN Membership"
  • set the PVID to the chosen VLAN , in the page "VLAN Interface Settings"

It's also better to remove all other VLAN from the interface.

It's seems the PVID were not correctly set on ports 3,4,5,6.

0

Generally, you need to use the same VLAN scheme on both sides - hosts don't use VLAN tags, so access ports are assigned an untagged VLAN.

Your question doesn't specify what you've configured on the router, although confirmed that by connecting to simple switch and connecting devices to that switch seems to indicate untagged ports.

Given that you're using one port for each VLAN (rather than a single VLAN trunk), you seem to use no tagging - that needs to be mirrored on the switch ports 1 and 2. With that you're then using purely port-based VLANs without any tagging (like two distinct switches).

If the router supports VLAN tagging (or tagged subinterfaces) you could use a single physical link between switch and router and tag the VLANs on that trunk. (A single "native" VLAN may remain untagged on the trunk.)

2
  • For some reason, I put port1 back on the default VLAN1, left everything untagged and it works perfect. I suspect somehow trying to assign port1 on a different VLAN messed things up. Thanks for your help!
    – steve
    Apr 7, 2022 at 20:50
  • That may mean you have simply a single network setup as you would with no VLAN configuration (as with an unmanaged switch). If that is how you want it, you're all set. If you want a second network, you need to select a range of ports, set them all to be untagged for a second VLAN and connect the second router interface to one of those ports. That will allow you a second network as described in the original question. You can then duplicate that configuration design so the first network uses a specific VLAN other than VLAN 1. It is generally not recommended to use the default VLAN. Jan 3, 2023 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.