0

I would need to configure a cross connect between two VPC networks via SFP Fiber. Unfortunately I'm new on BGP configuration and would need confirmation that I'm doing it on the right way...

I have Two VPC:

VPC A: ASN 200 IP Router: 169.254.250.1 Sub Network: 10.0.0.1/34

VPC B: ASN 100 IP Router: 169.254.250.2 linked with 4 Servers: 169.254.131.1 / 169.254.131.2 / 169.254.131.3 / 169.254.131.4

VPC A is completely configured, I purchased a Cisco router C1113-8PM to configure my VPC B. My aim is to ensure that any server on VPC A can access my 4 servers located in VPC B through BGP.

The procedure I started to write into VPC B Router:

#Configure ASN VPC B on Router
enable
configure terminal
router bgp 100
bgp router-id 169.254.250.2
timers bgp 70 120
end

# Configure ASN VPC A and routes
configure terminal
neighbor 169.254.250.1 remote-as 200
address-family ipv4 unicast
neighbor 169.254.250.1 activate
end

is it enough ? Do I need to set each IP address of my VPC B into BGP table ?

Concerning IP Configuration, I just set each interface with my local server IP:

ip routing
bridge 1 protocol dec
no clns routing
!
interface GigabitEthernet0/0/0
ip address 169.254.131.1 255.255.0.0
!
interface GigabitEthernet0/1/0
ip address 169.254.131.2 255.255.0.0
!
interface GigabitEthernet0/1/1
ip address 169.254.131.3 255.255.0.0
bridge-group 1
!
interface GigabitEthernet0/1/2
ip address 169.254.131.4 255.255.0.0
bridge-group 1
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface ATM0/2/0
ip address 169.254.250.2 255.255.0.0
bridge-group 1
3
  • 1
    Remember that you cannot route packets with link-local addresses in the 169.254.0.0/16 network. That is one of the IPv4 special address ranges that is reserved by IPv4 itself, and is not forwardable. Link-local means it is confined to a single link.
    – Ron Maupin
    Apr 8, 2022 at 12:25
  • "7. Router Considerations A router MUST NOT forward a packet with an IPv4 Link-Local source or destination address, irrespective of the router's default route configuration or routes obtained from dynamic routing protocols."
    – Ron Maupin
    Apr 8, 2022 at 17:16
  • Also, you cannot subnet the 169.251.0.0/16 range. "2.8. Link-Local Packets are Local The non-forwarding rule means that hosts may assume that all 169.254/16 destination addresses are "on-link" and directly reachable. The 169.254/16 address prefix MUST NOT be subnetted. This specification utilizes ARP-based address conflict detection, which functions by broadcasting on the local subnet. Since such broadcasts are not forwarded, were subnetting to be allowed then address conflicts could remain undetected."
    – Ron Maupin
    Apr 8, 2022 at 17:21

1 Answer 1

1

Your BGP router needs to advertise its networks to VPC A. You can either redistribute a static route or redistribute connected interfaces, depending on your topology.

I want to also mention that the 169.254.0.0/16 network is designated a link local subnet only. It is not intended to be advertised to other routers and many consider it poor practice to do so.

8
  • You are of course about 169.254.0.0/16 , the fact is AWS choosed to use it to pick /30 network for routing inside VPN tunnels (albeit you are not forced to use it).
    – JFL
    Apr 8, 2022 at 12:28
  • Yes, and I have configured AWS tunnels. But you don't have to advertise that link anywhere.
    – Ron Trunk
    Apr 8, 2022 at 12:33
  • ouch...my servers IP are already set....quite difficult to change them now....Hopefully we are not hosted by AWS....
    – tiamat
    Apr 8, 2022 at 12:33
  • when you say redistribute connected interface or static route, what is the difference ? I configured each connected interfaces with their respective IP Address, and I would need to use "ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name]" ?
    – tiamat
    Apr 8, 2022 at 12:35
  • 1
    The simplest (but may not be the best) way is to add redistribute connected under the address-family ipv4.
    – Ron Trunk
    Apr 8, 2022 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.