0

I have the following gns3 topology

enter image description here

I'm unable to ping R1 loopback interface (destination host unreachable) I'm not sure what is wrong

R1 configuration are shown below

hostname R1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login SSH-LOGIN local
!
!
!
!
!
aaa session-id common
no ip icmp rate-limit unreachable
!
!
!
!
ip dhcp pool POOL-102
 network 202.78.102.0 255.255.255.0
 default-router 202.78.2.1
!
!
!
no ip domain lookup
ip domain name wic2001.com
ip cef
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
username ---- secret 5 $1$D/vk$a8XNtzs/Cir2tVb/H7Lxv0
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 202.78.10.10 255.255.255.255
 ipv6 address 2001:202:78:10::10/128
!
interface Port-channel1
 ip address 100.100.23.1 255.255.255.252
 ipv6 address 2001:100:100::1/64
 hold-queue 150 in
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 ip address 202.78.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 hako
 negotiation auto
 ipv6 address 2001:202:78:1::1/64
 ipv6 ospf 1 area 0
!
interface GigabitEthernet2/0
 ip address 202.78.2.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 hako
 negotiation auto
 ipv6 address 2001:202:78:2::1/64
 ipv6 ospf 1 area 0
!
interface GigabitEthernet3/0
 no ip address
 negotiation auto
 channel-group 1
!
interface GigabitEthernet4/0
 no ip address
 negotiation auto
 channel-group 1
!
interface GigabitEthernet5/0
 ip address 202.78.5.1 255.255.255.0
 negotiation auto
 ipv6 address 2001:202:78:5::1/64
 ipv6 ospf 1 area 10
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router ospf 1
 router-id 1.1.1.1
 network 202.78.1.0 0.0.0.255 area 0
 network 202.78.2.0 0.0.0.255 area 0
 network 202.78.5.0 0.0.0.255 area 10
 default-information originate
!
router bgp 178
 bgp log-neighbor-changes
 neighbor 2001:100:100::2 remote-as 299
 neighbor 100.100.23.2 remote-as 299
 !
 address-family ipv4
  network 202.78.1.0
  network 202.78.2.0
  network 202.78.5.0
  network 202.78.101.0
  network 202.78.102.0
  network 202.78.103.0
  no neighbor 2001:100:100::2 activate
  neighbor 100.100.23.2 activate
 exit-address-family
 !
 address-family ipv6
  network 2001:202:78:1::/64
  network 2001:202:78:2::/64
  network 2001:202:78:5::/64
  network 2001:202:78:101::/64
  network 2001:202:78:102::/64
  network 2001:202:78:103::/64
  neighbor 2001:100:100::2 activate
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
ipv6 router ospf 1
 router-id 1.1.1.1
!
!
!
!
!
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login authentication SSH-LOGIN
 transport input ssh
!
!
end

R3:

hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 ip address 202.78.104.1 255.255.255.0
 negotiation auto
 ipv6 address 2001:202:78:104::1/64
 ipv6 ospf 1 area 10
!
interface GigabitEthernet2/0
 ip address 192.168.50.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 negotiation auto
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet4/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet5/0
 ip address 202.78.5.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 negotiation auto
 ipv6 address 2001:202:78:5::2/64
 ipv6 ospf 1 area 10
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router ospf 1
 router-id 4.4.4.4
 network 202.78.5.0 0.0.0.255 area 10
 network 202.78.104.0 0.0.0.255 area 10
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface GigabitEthernet5/0 overload
!
no cdp log mismatch duplex
ipv6 router ospf 1
 router-id 4.4.4.4
!
!
!
access-list 1 permit 192.168.50.0 0.0.0.31
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
 transport input all
!
!
end
1
  • There's no prefix suitable for the loopback IP address participating in OSPF.
    – Zac67
    Apr 18, 2022 at 6:03

2 Answers 2

2

The loopback interface in R1 is not in the OSPF domain. The network statements under router ospf do not include the loopback interface.

I see that you have the default-information originate statement as well. This would also work only if you already have a default route in your routing table. If you change the statement to default-information originate always, the router will always advertise a default route.

1

Your R1 Loopback0 interface has this address:

ip address 202.78.10.10 255.255.255.255

but you are not advertising that address in the R1 OSPF:

router ospf 1
 router-id 1.1.1.1
 network 202.78.1.0 0.0.0.255 area 0
 network 202.78.2.0 0.0.0.255 area 0
 network 202.78.5.0 0.0.0.255 area 10
 default-information originate
!

That means R3 has no idea how to reach the R1 Loopbak0 address, so it drops packets destined to that address.

You can add the R1 Loopback address to the R1 OSPF:

router ospf 1
 router-id 1.1.1.1
 network 202.78.1.0 0.0.0.255 area 0
 network 202.78.2.0 0.0.0.255 area 0
 network 202.78.5.0 0.0.0.255 area 10
 network 202.78.10.10 0.0.0.0 area 0   ! add this line
 default-information originate
!

You can add a static route on R3 to the R1 Loopback0:

ip route 202.78.10.10 255.255.255.255 GigabitEthernet5/0 202.78.5.1

You could add a default route to the R1 routing table:

ip route 0.0.0.0 0.0.0.0 Loopback0 202.78.10.10

You could make sure that R1 always advertises a default route:

router ospf 1
 router-id 1.1.1.1
 network 202.78.1.0 0.0.0.255 area 0
 network 202.78.2.0 0.0.0.255 area 0
 network 202.78.5.0 0.0.0.255 area 10
 default-information originate always   ! add the always keyword
!

Without the always keyword, R1 will only advertise a default route if it already has a default route in its routing table, but adding the keyword means that R1 will advertise a default route, even if it does not have a default route in its routing table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.