1

I need a bit of help understanding what is going on in my topology. I really want to understand why i can ping 1.1.1.1 from r4 but not from r5 or r6. Please help and advise me. Many thanks guys

enter image description here

r1

router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.13.0 0.0.0.255 area 0

router bgp 65537
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 1.1.1.3 remote-as 65537
 neighbor 1.1.1.3 update-source Loopback0

r2

router ospf 1
 network 1.1.1.2 0.0.0.0 area 0
 network 10.1.23.0 0.0.0.255 area 0

router bgp 65537
 bgp log-neighbor-changes
 network 1.1.1.2 mask 255.255.255.255
 neighbor 1.1.1.3 remote-as 65537
 neighbor 1.1.1.3 update-source Loopback0

r3

router ospf 1
 network 1.1.1.3 0.0.0.0 area 0
 network 10.1.13.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 0

router bgp 65537
 bgp log-neighbor-changes
 network 20.1.1.0 mask 255.255.255.0
 network 192.168.1.0
 neighbor 1.1.1.1 remote-as 65537
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 1.1.1.2 remote-as 65537
 neighbor 1.1.1.2 update-source Loopback0
 neighbor 1.1.1.2 next-hop-self
 neighbor 20.1.1.4 remote-as 65538
 neighbor 192.168.1.165 remote-as 65538
 maximum-paths 2

r4

router eigrp 100
 network 1.1.1.4 0.0.0.0
 network 10.2.45.0 0.0.0.255
 network 10.2.46.0 0.0.0.255

router bgp 65538
 bgp log-neighbor-changes
 network 20.1.1.0 mask 255.255.255.0
 network 192.168.1.0
 neighbor 1.1.1.5 remote-as 65538
 neighbor 1.1.1.5 update-source Loopback0
 neighbor 1.1.1.5 next-hop-self
 neighbor 1.1.1.6 remote-as 65538
 neighbor 1.1.1.6 update-source Loopback0
 neighbor 1.1.1.6 next-hop-self
 neighbor 20.1.1.3 remote-as 65537
 neighbor 192.168.1.191 remote-as 65537
 maximum-paths 2

r5

router eigrp 100
 network 1.1.1.5 0.0.0.0
 network 10.2.45.0 0.0.0.255

router bgp 65538
 bgp log-neighbor-changes
 network 1.1.1.5 mask 255.255.255.255
 neighbor 1.1.1.4 remote-as 65538
 neighbor 1.1.1.4 update-source Loopback0

r6

router eigrp 100
 network 1.0.0.0
 network 1.1.1.6 0.0.0.0
 network 10.2.46.0 0.0.0.255

router bgp 65538
 bgp log-neighbor-changes
 network 1.1.1.6 mask 255.255.255.255
 neighbor 1.1.1.4 remote-as 65538
 neighbor 1.1.1.4 update-source Loopback0

r6

    #show ip bgp
    
         Network          Next Hop            Metric LocPrf Weight Path
     *>i  1.1.1.1/32       1.1.1.4                  0    100      0 65537 i
     *>i  1.1.1.2/32       1.1.1.4                  0    100      0 65537 i
     *>   1.1.1.6/32       0.0.0.0                  0         32768 i
     *>i  20.1.1.0/24      1.1.1.4                  0    100      0 i
     *>i  192.168.1.0      1.1.1.4                  0    100      0 i

and as well r4

    show ip bgp sum
    Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1.1.1.5         4        65538      52      54        9    0    0 00:43:20        1
    1.1.1.6         4        65538      53      53        9    0    0 00:43:25        1
    20.1.1.3        4        65537      54      54        9    0    0 00:43:20        4
    192.168.1.191   4        65537      56      53        9    0    0 00:43:17        4

show ip bgp


     Network          Next Hop            Metric LocPrf Weight Path
 *m   1.1.1.1/32       192.168.1.191                          0 65537 i
 *>                    20.1.1.3                               0 65537 i
 *m   1.1.1.2/32       192.168.1.191                          0 65537 i
 *>                    20.1.1.3                               0 65537 i
 r>i  1.1.1.5/32       1.1.1.5                  0    100      0 i
 r>i  1.1.1.6/32       1.1.1.6                  0    100      0 i
 *    20.1.1.0/24      20.1.1.3                 0             0 65537 i
 *                     192.168.1.191            0             0 65537 i
 *>                    0.0.0.0                  0         32768 i
 *    192.168.1.0      20.1.1.3                 0             0 65537 i
 *                     192.168.1.191            0             0 65537 i
 *>                    0.0.0.0                  0         32768 i

a ping from r4 to r1 or r2 is successful but from r5 or r6 is not.

7
  • 1
    Please do not use public IP addresses that you do not own, not even in an example. Also, add the used addresses to your diagram as we can currently only guess what's where.
    – Zac67
    May 23, 2022 at 7:14
  • Include show bgp from R 3
    – Ron Trunk
    May 23, 2022 at 10:49
  • You never redistribute between OSPF and BGP, and between EIGRP and BGP, so eBGP cannot advertise those prefixes between R3 and R4.
    – Ron Maupin
    May 23, 2022 at 12:30
  • why are you running two dynamic routing protocols on each router in your network? May 23, 2022 at 17:16
  • In my experience, this setup with OSPF and EIGRP is fairly normal. It's common to run BGP as the EGP and some other IGP as the glue holding the internal structure together. What's unusual here is that the EGP is carrying a bunch of internal nets, like loopbacks. Typically, you would selectively redistribute parts of your IGP into your EGP. (In case anyone is wondering, this topology would be like two separate companies, each with their own IGP, connected to each other with BGP.) Nov 19, 2022 at 2:56

2 Answers 2

0

It looks to me like this is just a case of not having all the networks being advertised. When R5 and R6 send a ping over to anything on the left-hand side, they will source the icmp packet from their nearest interface to where the packet is going. That means their source IP will be 10.2.45.x or 10.2.46.x. Those two subnets are in EIGRP, but they're not shared to R3, R2, and R1 using BGP. So the other side receives the ping packets but doesn't know how to send the responses back. If you were to do an extended ping on R5 or R6 and source it from the loopback, I suspect it would all work.

For example:

R5# ping 1.1.1.1 source loopback0

To solve the issue, I expect you can probably just advertise the 10.2.x.x nets in BGP. For example:

R4(config)# router bgp 65538
R4(config-router)# network 10.2.45.0 mask 255.255.255.0
R4(config-router)# network 10.2.46.0 mask 255.255.255.0

I expect you also have the same problem mirrored. So, you'd need to add 10.1.13.0/24 and 10.1.23.0/24 to BGP on R3.

0

Both AS should have no route about 1.1.1.x/32's and internal subnet's because you don't announced them in BGP. Routing is impossible according to the these configs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.