2

My network consist of 4 routers:

  1. R1(with loop back network of 11.0.0.0)
  2. R2(with loop back network of 12.0.0.0)
  3. R3(with loop back network of 13.0.0.0)
  4. R4(with loop back network of 14.0.0.0)

R3 is my ABR and R4 is ASBR route having external RIP routes and redistributed to OSPF. R1, R2, and R3 belong to area 10 whereas R3 and R4 belong to area 0.

I have configured the area 10 as stub area and done all the necessary configuration in R1,R2 and R3. All is working fine but one thing i'm amazed that i have not advertised the loopbacks of R1 and R3 in ospf but still im able to reach them and when i remove the stub area they became unreachable. Please help me on this

R1:

R1(config-router)#do sh run
Building configuration...

Current configuration : 1283 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 12.0.0.1 255.255.255.0
!
interface Loopback2
 ip address 12.0.1.1 255.255.255.0
!
interface Loopback3
 ip address 12.0.2.1 255.255.255.0
!
interface Loopback43
 ip address 12.0.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 ip address 1.1.1.1 255.255.255.252
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 2.2.2.1 255.255.255.252
 negotiation auto
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 area 10 stub
 network 1.1.1.0 0.0.0.3 area 10
 network 2.2.2.0 0.0.0.3 area 10
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R2:

R2(config-router)#do sh run
Building configuration...

Current configuration : 1300 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback0
 ip address 11.0.0.1 255.255.255.0
!
interface Loopback1
 ip address 11.0.1.1 255.255.255.0
!
interface Loopback2
 ip address 11.0.2.1 255.255.255.0
!
interface Loopback3
 ip address 11.0.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 ip address 1.1.1.2 255.255.255.252
 negotiation auto
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 area 10 stub
 network 1.1.1.0 0.0.0.3 area 10
 network 11.0.0.0 0.0.0.3 area 10
 network 11.0.1.0 0.0.0.3 area 10
 network 11.0.2.0 0.0.0.3 area 10
 network 11.0.3.0 0.0.0.3 area 10
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R3:

Building configuration...

Current configuration : 1501 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback0
 ip address 13.0.0.1 255.255.255.0
!
interface Loopback1
 ip address 13.0.1.1 255.255.255.0
!
interface Loopback2
 ip address 13.0.2.1 255.255.255.0
!
interface Loopback3
 ip address 13.0.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown 
 duplex half
!
interface GigabitEthernet1/0
 ip address 2.2.2.2 255.255.255.252
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 3.3.3.2 255.255.255.252
 negotiation auto
!
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 area 10 stub
 redistribute rip
 network 2.2.2.0 0.0.0.3 area 10
 network 3.3.3.0 0.0.0.3 area 0
 network 13.1.0.0 0.0.0.255 area 10
 network 13.1.1.0 0.0.0.255 area 10
 network 13.1.2.0 0.0.0.255 area 10
 network 13.1.3.0 0.0.0.255 area 10
!
router rip
 version 2
 network 3.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
 shutdown 
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login    
!
end

R4:

R4(config-router)#do sh run
Building configuration...

Current configuration : 1232 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback0
 ip address 14.0.0.1 255.255.255.0
!
interface Loopback1
 ip address 14.0.1.1 255.255.255.0
!
interface Loopback2
 ip address 14.0.2.1 255.255.255.0
!
interface Loopback3
 ip address 14.0.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown 
 duplex half
!
interface GigabitEthernet1/0
 ip address 3.3.3.1 255.255.255.252
 negotiation auto
!
router ospf 200
 log-adjacency-changes
 redistribute rip subnets
 network 3.3.3.0 0.0.0.3 area 0
!
router rip
 version 2
 network 3.0.0.0
 network 14.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
 shutdown 
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login    
!
end 
3
  • 1
    A diagram is worth a 1000 words
    – manish ma
    Jun 2 at 14:42
  • 1
    Please edit your question to include the configurations of your routers (we can't just guess). Use the preformatted { } text option. Also, a simple diagram would be helpful.
    – Ron Trunk
    Jun 2 at 14:52
  • 1
    Also, do not post images of your configurations. Use the preformatted text option.
    – Ron Trunk
    Jun 2 at 14:54

1 Answer 1

2

Since you've defined area 10 as a stub area, R3 generates a default route into the area. All routers in area 10 have this default route.

When you ping 12.0.3.1, R2 uses its default route to forward the packet to R1. The source address is the closest interface, namely 1.1.1.2.

When R1 receives the packet, the destination is a connected interface, so it forwards it to the loopback interface.

The reply is forwarded out gi1/0, since the reply destination (the original source address) is also a connected interface.

1
  • thank you so much for clarification. Jun 4 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.