2

routers with ASBR2 connecting to AREA 0 and 10 and ASBR1 connecting to area 0 and 20, there's no entry of routes in R1's routing table, help me out

R1#sh run
Building configuration...

Current configuration : 1080 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
! 
!
!
ip cef
no ipv6 cef 
! 
!
! 
! 
license udi pid CISCO2911/K9 sn FTX1524NHN4-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback1
ip address 172.16.10.1 255.255.255.255  
! 
interface Loopback2
ip address 172.31.10.1 255.255.255.255
!
interface Loopback100
no ip address 
!
interface GigabitEthernet0/0
ip address 11.10.10.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 12.10.10.1 255.255.255.252
duplex auto
speed auto 
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown 
!
interface Vlan1
no ip address
shutdown
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 172.16.10.0 0.0.0.0 area 0
network 172.31.10.0 0.0.0.0 area 0
network 11.10.10.0 0.0.0.3 area 0
network 12.10.10.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end



ASBR1#sh run
Building configuration...

Current configuration : 1080 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
! 
!
!
ip cef
no ipv6 cef 
! 
!
! 
! 
license udi pid CISCO2911/K9 sn FTX1524NHN4-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 12.10.10.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto 
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown 
!
interface Vlan1
no ip address
shutdown
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
network 192.168.20.0 0.0.0.255 area 20
network 12.10.10.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

R1#sh run
Building configuration...

Current configuration : 1080 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
! 
!
!
ip cef
no ipv6 cef 
! 
!
! 
! 
license udi pid CISCO2911/K9 sn FTX1524NHN4-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback1
ip address 172.16.10.1 255.255.255.255  
! 
interface Loopback2
ip address 172.31.10.1 255.255.255.255
!
interface Loopback100
no ip address 
!
interface GigabitEthernet0/0
ip address 11.10.10.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto 
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown 
!
interface Vlan1
no ip address
shutdown
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
network 11.10.10.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 10
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
1
  • 1
    I guess you should try to use "redistribute connected" in ASBR ospf config. Besides, "network 172.16.10.0 0.0.0.0 area 0" will not match Loopback interface in ASBR1 therefore it has no sense. What routes do you expect on R1?
    – kab00m
    Jun 23 at 10:20

1 Answer 1

2

OSPF will not make up addresses, so the two network statements:

network 172.16.10.0 0.0.0.0 area 0
network 172.31.10.0 0.0.0.0 area 0

are trying to use interfaces that do not exist on your router (172.16.10.0 and 172.31.10.0). Your loopbacks are 172.16.10.1 and 172.31.10.1.

Remember that the OSPF network statements are used to tell OSPF which interfaces are participating in the OSPF process, not which networks to advertise.

You could do it several ways, such as:

network 172.16.10.1 0.0.0.0 area 0
network 172.31.10.1 0.0.0.0 area 0
network 11.10.10.0 0.0.0.3 area 0
network 12.10.10.0 0.0.0.3 area 0

-or-

network 172.0.0.0 0.255.255.255 area 0
network 11.10.10.0 0.0.0.3 area 0
network 12.10.10.0 0.0.0.3 area 0

-or even something like-

network 0.0.0.0 255.255.255.255 area 0

that would match all interfaces.


Since you are not redistributing routes into OSPF on any router, you really do not have an ASBR, which is an OSPF router that redistributes external routes into OSPF. An ABR connects different areas to Area 0, and an ASBR redistributes external routes into OSPF (E1 or E2 routes).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.