1

I am trying to create a network with two subnetworks with private IPs. I need to configure symmetric NAT on edge routers within the subnetwork.

Diagram:

Diagram

I need to configure NAT on Router0 and Router2.

Router0 config -

interface GigabitEthernet0/0
 ip address 129.0.0.1 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.16.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool net1 129.0.0.1 129.0.0.1 netmask 255.255.255.255
ip nat inside source list INSIDE-NET pool net1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 129.0.0.2 

Router1 config -

interface GigabitEthernet0/0
 ip address 129.0.0.9 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 129.0.0.5 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 129.0.0.2 255.255.255.252
 duplex auto
 speed auto
!

Router2 config -

interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 129.0.0.10 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
!
ip nat pool net1 129.0.0.10 129.0.0.10 netmask 255.255.255.255
ip nat inside source list INSIDE-NET pool net1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 129.0.0.9 

Currently, I am able to configure Dynamic NAT with a single outside IP overload.

If I try to ping from 192.168.0.2 the translation table on Router2:

translation_table

If I am not wrong, this is a symmetric NAT. Is it possible to configure full cone NAT on the Cisco router in Packet Tracer? If so, what should I change, or is there any documentation explaining that?

Thank you.

5
  • Please edit your question to include a good network description or diagram and the router configuration for the router on which you want to configure this. We cannot guess at your configuration.
    – Ron Maupin
    Jul 9, 2022 at 19:07
  • Thanks for your suggestion. I have added the diagram.
    – Filip
    Jul 9, 2022 at 20:10
  • Please enter the router configurations. The drawing seems to show invalid addressing. We cannot guess how you have configured the routers.
    – Ron Maupin
    Jul 9, 2022 at 20:40
  • I have fixed, the subnets in notes, but I don't see any other problem in addressing. The routers are configured, as it's shown in the picture. The interface's IP addresses are in the diagram and routers have default routes configured (also described in the diagram). PCs have an IP address and default GW also described in the diagram.
    – Filip
    Jul 9, 2022 at 20:58
  • Again, please edit the question to include the router configurations. We cannot guess how you have configured the routers, and we will help you fix the configurations, but we will not write the configurations for you. Unless you put in some effort, you are likely to get down votes for which the definition is, "This question does not show any research effort; it is unclear or not useful." You will see that when hovering the mouse pointer over the down arrow on a question.
    – Ron Maupin
    Jul 9, 2022 at 21:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.