4

I recently tried the command "no autostate" on a GigabitEthernet interface (on a newer router) and this didn't work anymore, does anyone know why this is occuring? This use to work on FastEthernet interfaces. Any alternative suggestions?

Working configuration: (Cisco router 881)

Interface vlan 2
no autostate

Not working: (Cisco router 1921)

Interface vlan 2
no autostate
  • I have to ask - why would you want to turn this off? – John Jensen May 22 '13 at 5:38
  • @JohnJensen When you set up vpn's for company's, they want to test the connectivity without having their LAN yet connected, so they ping their router that is present at that location. So it's used for test purposes. – Bulki May 22 '13 at 5:40
  • Makes sense. What hardware platform are you working with? – John Jensen May 22 '13 at 5:42
  • 2
    What about putting the IP on a loopback instead for testing? – Daniel Dib May 22 '13 at 5:54
  • @DanielDib This could be a solution to test indeed. The only disadvantage with that setup is that you have to change it again to allow the user to eventually use his setup. With 'no autostate' you just put the interface in autostate again even when the connection is already used. – Bulki May 22 '13 at 5:58
4

After some research and questioning with cisco specialists, we can conclude that in newer versions of IOS and newer routers, autostate is applied by default and unchangeable. (so the "no autostate" will not work anymore on vlan's).

  • Do you have any references on this? I would love to read some more. – JelmerS May 22 '13 at 14:13
  • @JelmerS I've asked this question to one of the specialists I know. I'll ask a reference and get back 2 you. – Bulki May 23 '13 at 6:11
4

Because autostate is a feature of switch virtual interfaces (read: vlans.) From the horse's mouth: [click here]

Perhaps you want no keepalive.

[edit] Oddly, Feature Navigator only shows autostate exclude as available on cats. However, my 1720 (WIC-4ESW) allows it. (12.4(23) IP/ADSL)

[edit 2] I just looked through the 1921 15.1(4)M1 universal image, and autostate is in there:

% strings -a C1900-UN.BIN | grep -i autostate
no autostate
autostate
Enable autostate determination for VLAN
  • Note: at the time the question read int Fa0 and int Ge0 – Ricky Beam May 22 '13 at 6:34
  • Indeed, srry about that, but this was pointed out by your question :) I've had the non-functionality with vlan's, that's why this is so strange to me. – Bulki May 22 '13 at 6:38
  • @Bulki, unless I'm mistaken a Cisco 881 doesn't support Vlan interfaces... could you please post "show mod" output from both devices this has been tested on? – Mike Pennington May 22 '13 at 6:40
  • @MikePennington indeed, unless you add a HWIC – Bulki May 22 '13 at 6:45
  • 1
    @MikePennington google image search FTW – Ricky Beam May 22 '13 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.