0

I have a 800-Series router connected in the following configuration:

  • Port GigabitEthernet7 is connected to an external server (192.0.2.251) that sends unicast UDP to destinations 192.0.2.42:45100 and 192.0.2.44:45100

  • Port GigabitEthernet1 is connected to two internal servers (via a bridge) with addresses 192.168.210.31 and 192.168.210.32

The two internal servers are supposed to receive the same data received on GigabitEthernet7. The source address in the received packets should be 220.120.121.120

The following configuration is used:

ethernet lmi ce
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
interface Loopback1110
ip address 220.120.121.120 255.255.255.0
ip nat enable
!
interface GigabitEthernet1
description Internal_Network
switchport access vlan 2
no ip address
!
interface GigabitEthernet7
description External_Network
switchport access vlan 3
no ip address
!
interface Vlan2
ip address 192.168.210.250 255.255.255.0
ip directed-broadcast
ip nat enable
ip virtual-reassembly in
!
interface Vlan3
ip address 192.0.2.250 255.255.255.0
ip directed-broadcast
ip nat enable
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat source list NATT interface Loopback1110 overload
ip nat source static udp 192.168.210.255 45100 192.0.2.42 45100 extendable
!
ip access-list extended NATT
permit ip 192.0.2.0 0.0.0.255 any

I configured my laptop with address 192.168.210.211 and connected it to GigabitEthernet1 and sniffed data (using Wireshark). However, nothing is received. However, when I change the second NAT line above to 

ip nat source static udp 192.168.210.31 45100 192.0.2.42 45100 extendable

I successfully receive data on the unicast address 192.168.210.31.

What I need is to receive data by both servers connected to that port.

PS:

I tried ip forward-protocol nd but didn't get a different result. 

I also tried ip multicast-routing but the same result.

7
  • Are you trying to mirror traffic to an interface? You probably cannot do that on a switch module in a router because those do not provide advanced switch features.
    – Ron Maupin
    Commented Sep 15, 2022 at 22:03
  • Also, devices on the inside of the NAT will not receive packets with the NAT address as the source address. Devices on the outside of the NAT will receive packets with the NAT address as the source, but not for devices inside the NAT.
    – Ron Maupin
    Commented Sep 15, 2022 at 22:06
  • @RonMaupin I actually could mirror traffic to a unicast address. What I want is to do the same but for a broadcast address.
    – O. Salah
    Commented Sep 16, 2022 at 9:43
  • Broadcasts cannot cross routers; they are confined to the network on which they originate.
    – Ron Maupin
    Commented Sep 16, 2022 at 12:10
  • @RonMaupin I don't want to pass broadcasts through the router. I just want to re-broadcast unicast udp packets. That is, the input is unicast and the output is broadcast.
    – O. Salah
    Commented Sep 16, 2022 at 20:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.