0

I bought a public IP from my ISP and they provided me with the following details.

WAN IP :10.129.69.157 LAN IP : 196.188.173.32/30

How do I configure this on my side ?

The told me to do configure as following

IP : :10.129.69.158
GATEWAY : :10.129.69.157
SUBNET : /29

then change the to

IP :  196.188.173.32
GATEWAY :  10.129.69.157
SUBNET :  /29

With this technique I was able access my servers briefly but after a few hours the connection fails.

0

2 Answers 2

3

Actually, while is this is a strange application, the scenario that your ISP assigned to you is perfectly functional. What they're telling you is that you assign the 196.x.x.x address on your local LAN side, and you assign the 10.x.x.x address on your upstream WAN side. You then tell your router that his default route (or his 0.0.0.0/0 static route) is 10.129.69.157.

This works because of the following two principles:

  1. Inbound: Your ISP advertises your 196.x.x.x addresses to the rest of the internet on your behalf. Once the internet is attracted over to your ISP, your ISP static routes it to your 10.x.x.x address. Your router is directly attached to the 196.x.x.x so he delivers it directly to the recipient.
  2. Outbound: You tell your router that 0.0.0.0/0 is available via the ISP's address of 10.129.69.157. Your router forwards it out the uplink to the ISP and the rest is automatic.

Using RFC1918 addresses on WAN transit links helps the ISP conserve valuable public address space that is in high demand.

The only drawback to this scenario (which is BARELY a drawback) is that 10.129.69.x will be visible in traceroutes. And actually, the ISP may have their equipment set to not respond with TTL-expired messages anyways (which is how traceroutes work), so you'll just see a hop that times out. This is inconsequential and doesn't affect the performance of the circuit in any way.

[Edit]

I realize that you may need slightly more help. What the tech at your ISP told you to do does work for a short period of time because it relies on Proxy-ARP. This is not a long-term solution whatsoever. That guy (or gal) should take a networking course.

What you should do on your router is the following:

  1. Set your WAN address to this:
IP : :10.129.69.158
MASK : 255.255.255.248
  1. Set your LAN address to this:
IP :  196.188.173.33
MASK :  255.255.255.252
  1. Set your "default route" to 10.129.69.157. In "Cisco Language" that would be ip route 0.0.0.0 0.0.0.0 10.129.69.157
  2. Test and rejoice!

[Edit again]

By the way, there are more clever ways to use what they gave you, one of which would be to use something like a firewall. You would assign the firewall the WAN address that I mentioned previously, and add the default route. Then, you would configure static NATs for private devices behind the firewall to use the 4 static addresses that your ISP assigned to you (you noticed the mask was a /30, right?).

[Edit again again]

Your question was edited by a moderator, so a few details were lost in translation. I think the WAN address on your router should probably be 10.129.69.157, and the default route should probably point to 10.129.69.158. Your initial post doesn't specify what your ISP gave you as the default route, so i'm only taking an educated guess.

4
  • Using RFC1918 addresses in the path of public IPs is a very bad practice. If for any reason, that router needs to send an ICMP message, it will have a non-sense address. And yes, this breaks things in ways that confuse everyone. It's also possible they NAT that address at the edge.
    – Ricky
    Commented Nov 16, 2022 at 0:01
  • You don't have to try to convince me. I'm not the ISP that assigned it. Commented Nov 16, 2022 at 1:10
  • Thank you everyone who tried to help me, The issue was solved. Per the instruction, I assigned my edge router WAN address with the 10.129.69.157 Address and assigned the 196.188.173.33 address on the LAN. The weird thing is I can connect to my public IP from remote location but when I check my IP address it shows me different public address( 196.188.179.250 ).
    – Tinsae
    Commented Nov 16, 2022 at 11:36
  • The most important thing to do : NAT function needs to be disabled on the router
    – Tinsae
    Commented Dec 22, 2022 at 11:46
2

That should not work as configured and your device or operating system should refuse to implement that configuration. Contact your ISP to ask for more details, they have given you incomplete or incorrect information. The gateway address MUST be part of the network configured on your network interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.