I have this simple 3 router network that I need to configure the OSPF for, when using two routers every thing works fine and i can ping but when I add the third router nothing works
left router
interface se0/1/0
ip address 200.20.20.1 255.255.255.252
no sh
interface gig0/0/0
ip address 192.168.3.1 255.255.255.224
no sh
router ospf 1
network 200.20.20.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.31 area 0
interface loopback 100
ip address 100.0.0.1/30
middle router
interface se0/1/0
ip address 200.20.20.2
no sh
interface se0/1/1
ip address 200.20.20.10
no sh
interface gig0/0/0
ip address 192.168.3.33 255.255.255.224
no sh
router ospf 1
network 200.20.20.0 0.0.0.3 area 0
network 200.20.20.8 0.0.0.3 area 0
network 192.168.3.32 0.0.0.31 area 0
right router
interface se0/1/0
ip address 200.20.20.9 255.255.255.252
no sh
interface gig0/0/0
ip address 192.168.3.65 255.255.255.224
no sh
router ospf 1
network 200.20.20.8 0.0.0.3 area 0
network 192.168.3.65 0.0.0.31 area 0
Can somebody please explain what is am I missing here?