1

I try to rename a file on a Cisco 2911 router by issuing

rename flash:/asa842-k8.bin flash:/old.bin

but get the error message

Router#rename flash:asa842-k8.bin flash:old.bin
              ^
% Invalid input detected at '^' marker.
    
Router#

I also tried

rename flash:asa842-k8.bin flash:old.bin

but the same error occurs. Is there any other command?

Edit the flash looks like this

Router#dir flash:
Directory of flash0:/

    5  -rw-     5571584          <no date>  asa842-k8.bin
    3  -rw-    33591768          <no date>  c2900-universalk9-mz.SPA.151-4.M4.bin
    2  -rw-       28282          <no date>  sigdef-category.xml
    1  -rw-      227537          <no date>  sigdef-default.xml

255744000 bytes total (216324829 bytes free)

I am using Cisco packet tracer

10
  • Are you sure the url is correct? try dir flash:
    – Ron Trunk
    Dec 13, 2022 at 18:24
  • Hi and thank you. I have added the output into the question.
    – MBrain
    Dec 13, 2022 at 18:27
  • did you try flash0?
    – Ron Trunk
    Dec 13, 2022 at 18:27
  • Yes i did but the same result.
    – MBrain
    Dec 13, 2022 at 18:28
  • 4
    Oh ok if this is packet tracer, well everything is possible. It is a limited simulator and we can expect major differences with real devices. Actually what would surprise me is that you were able to alter the flash of devices in packet tracer.
    – JFL
    Dec 13, 2022 at 18:53

1 Answer 1

5

Following the edit explaining this is actually within Packet Tracer, this is to be expected.

Packet Tracer doesn't run real IOS software, it only simulates basic features of Cisco devices, mainly targeted at CCNA courses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.