-1

I am, admittedly, rather lacking in networking knowledge. However, I managed to learn quite a lot of server and development skills through trial & error and by asking various people/forums. I hope this post isn't too fundamental or basic to be asked here.

I've tried various resources, including:
https://aristanetworks.force.com/AristaCommunity/s/article/internet-bgp-peering-examples-for-enterprises
https://aristanetworks.force.com/AristaCommunity/s/article/bgp-primer-for-internet-peering
https://www.youtube.com/watch?v=0-q_Tu-n1hE
... in addition to a dozen others that I neglected to keep track of.

To summarize, here's my setup.

We have 1Gbps Transit from Cogent, and a single fiber drop into our rack. We have an Arista DCS-7048T-A, and FS.com transceivers. The transceiver in use is plugged into port 50, and we have experimented with 49 and 51, in addition to swapping the leads around.

Here's the commands I've ran, following a fullrecover, and they have no result:

ra01.tor01.nola(config-if-Et50)#int e50
ra01.tor01.nola(config-if-Et50)#no switchport
ra01.tor01.nola(config-if-Et50)#ip addr 38.142.114.97/29
ra01.tor01.nola(config-if-Et50)#router bgp 963
ra01.tor01.nola(config)#router bgp 963
ra01.tor01.nola(config-router-bgp)#neighbor 38.142.114.97 remote-as 174
ra01.tor01.nola(config-router-bgp)#network 38.127.1.0/24
ra01.tor01.nola(config-router-bgp)#exit
ra01.tor01.nola(config)#show ip bgp summary
BGP router identifier 38.142.114.97, local AS number 963
Neighbor         V  AS      MsgRcvd   MsgSent  InQ OutQ  Up/Down State  PfxRcd
38.142.114.97    4  174           0         0    0    0 00:00:41 Active

Here's the result of show active on if-Et50:

interface Ethernet50
   no switchport
   ip address 38.142.114.97/29

Here's the result of show active on router-bgp:

router bgp 963
   bgp log-neighbor-changes
   neighbor 38.142.114.97 remote-as 174
   neighbor 38.142.114.97 maximum-routes 12000 
   network 38.127.1.0/24

For further clarification, we are assigned 38.142.114.96/29. The default gateway is .97, and the peering IP is .98. The fiber drop is confirmed working with adequate light levels.

We have spent roughly 5+ hours trying to get our setup working with no result. We truly appreciate any help, and again apologize if this kinda question is not one that should be asked here.

2
  • Typically, the carrier will have the lower address, so you must use the .98 address on your interface because you are trying to create a neighbor to the .97 address.
    – Ron Maupin
    Dec 22, 2022 at 19:00
  • We've changed the e50 interface to use 38.142.114.98/29, though it is unsuccessful in yielding any meaningful result.
    – Zander
    Dec 22, 2022 at 19:03

2 Answers 2

2

As you say:

we are assigned 38.142.114.96/29. The default gateway is .97, and the peering IP is .98.

That means your interface IP address should be 38.142.114.98, or... possibly it should be 38.142.114.99

I say that because your statement "peering IP is .98" is unclear. It may mean that your interface IP address is .98 as Cogent are telling you that you, as the peer, should use that IP address, or they could be telling you that your peer session needs to be established with that IP address (meaning you need to configure your neighbor to be that IP address).

Start by setting your IP address to .99 and try to ping .97 and see how it goes. Then try to ping .98

If both reply, then you know that .98 is in use and is probably the neighbor you should peer with. Or just double check with Cogent to clarify what they mean.

Also, it sounds from your config like they are providing you a /24 network (38.127.1.0/24). Is there any reason you are using BGP at all since you seem to be limiting the routes you will accept to only 12000? That's a tiny fragment of the 900k+ routes on a full table. With that small a list of routes, you might as well just have them give you a default route and nothing else or not use BGP at all unless you have arranged with them to use those IP addresses over another ISP connection or something like that.

If you get things working, talk to them about using a BGP secrect/password for your peer session and make sure they have a whitelist for the IP address networks they will accept from you. It makes it much more secure to do BGP that way.

2
  • Hey, after a bit of troubleshooting, we realized that we have a 850nm transceiver while Cogent is doing 1310nm - a bit of an odd mistake on our part. We are doing BGP primarily because it makes sense for our business, and it allows us to better facilitate BYOIP services. Additionally, it seems to be the most ideal solution for our DDoS protection setup. We will most likely setup a default route on our router at the end of the day, though by already paying for our BGP session we are easily able to upgrade our hardware to support a full routing table without further orders or real setup.
    – Zander
    Dec 23, 2022 at 18:46
  • Makes sense, and yeah that would be an issue if you are not matching the transceiver to the service handoff media (single mode vs multimode). Best of luck now that you have it figured out. Dec 26, 2022 at 3:12
0

The default gateway is .97 - you have assigned that exact address to port e50. Most likely you need to use another address, 38.142.114.98 seems reasonable.

The most basic troubleshooting steps are - working up the layers:

  1. check the device log for anomalies - duplicate IP addresses etc
  2. verify physical layer linkage - LED, up status, etc
  3. verify data link layer connectivity - the far MAC addresses should show up on the port's MAC table
  4. verify network layer connectivity - ping the (default) gateway; if ping fails (ICMP might be filtered), check the ARP cache for successful resolution
  5. ping more remote destinations to see if routes work
  6. verify DNS resolution is working
2
  • Hey, thanks for the advice! We've changed port e50 to use 38.142.114.98: no ip addr 38.142.114.97/29 ip addr 38.142.114.98/29 Everything is operating physically, though we are unsure how to check the device log. Arista's knowledgebase only gives information on enabling logs, though I'm unsure how to access them.
    – Zander
    Dec 22, 2022 at 18:49
  • Have you tried show logging? Additionally, Arista gear seems to be able to tap the underlying Linux's log: bash sudo tail /var/log/messages
    – Zac67
    Dec 22, 2022 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.