0

I have a topology of PCs A, B, D, and E, 2 routers R1 and R2, and 4 switches A, B, D, and E for each of my PCs respectively.

PC A IP is 201.4.100.1/28 with a default gateway of 201.4.100.2, 
PC-B IP is 201.4.100.17/29 with a default gateway of 201.4.100.18, 
PC-D IP is 201.4.100.33/27 with a default gateway of 201.4.100.34, 
PC-E IP is 201.4.100.65/29 with a default gateway of 201.4.100.66. 

R1 **LAN g0/0** ip is 201.4.100.14/28, **LAN g0/1** ip is 201.4.100.22/29 and **WAN s0/0/0** ip is 201.4.100.25/30. 
R2 **LAN g0/0** is 201.4.100.62/27, **LAN g0/1** ip is 201.4.100.70/29, **WAN s0/0/0** ip is 201.4.100.26/30. 

They are subnets A B C D E subnet numbers 0, 1, 2, 4, and 6 respectively. Subnet addresses 201.4.100.0/28(A), 201.4.100.16/29(B), 201.4.100.24/30(C), 201.4.100.32/27(D), 201.4.100.64/29(E) respectively.

The network address number is 201.4.100.0/24.

Switches A, B, D, and E have Vlan1 IPs of

201.4.100.3/28 and default gateway 201.4.100.2(**A**), 
201.4.100.19/29 and default gateway 201.4.100.18(**B**), 
201.4.100.35/27 and default gateway 201.4.100.34(**D**), 
201.4.100.67/29 and default gateway 201.4.100.66(**E**). 

My problem is that my PCs are only able to ping their respective switches and the rest fails to ping successfully like default gateway, routers, and pcs. On the other hand, R1 and R2 can ping each other successfully, and R1 can ping Switches and PCs A and B but not D and E, as well as all the default gateways. R2 can ping Switches and PCs D and E but not A and B, as well as all the default gateways. I need to be able to ping PC-B to PC-A, PC-E to PC-D, and PC-A to D.

And also R1 and R2 are connected by a Serial DCE clock rate of 128000 to DTE

subnets A, B, C, D, and E are to have 10, 6, 2, 26, and 5 usable IP addresses respectively. And also therefore a mask of /28, /29, /30, /27, and /29 was used.My topology

R1 config

    R1#show run
Building configuration...

Current configuration : 997 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15245POI-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 201.4.100.14 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 201.4.100.22 255.255.255.248
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 201.4.100.25 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 201.4.100.24 255.255.255.252 201.4.100.32 
ip route 201.4.100.24 255.255.255.252 201.4.100.64 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R1 routing

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     201.4.100.0/24 is variably subnetted, 6 subnets, 4 masks
C       201.4.100.0/28 is directly connected, GigabitEthernet0/0
L       201.4.100.14/32 is directly connected, GigabitEthernet0/0
C       201.4.100.16/29 is directly connected, GigabitEthernet0/1
L       201.4.100.22/32 is directly connected, GigabitEthernet0/1
C       201.4.100.24/30 is directly connected, Serial0/0/0
L       201.4.100.25/32 is directly connected, Serial0/0/0

R2 config

R2#show run
Building configuration...

Current configuration : 977 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15245B3Q-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 201.4.100.62 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 201.4.100.70 255.255.255.248
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 201.4.100.26 255.255.255.252
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 201.4.100.24 255.255.255.252 201.4.100.0 
ip route 201.4.100.24 255.255.255.252 201.4.100.16 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R2 routing

    R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     201.4.100.0/24 is variably subnetted, 6 subnets, 4 masks
C       201.4.100.24/30 is directly connected, Serial0/0/0
L       201.4.100.26/32 is directly connected, Serial0/0/0
C       201.4.100.32/27 is directly connected, GigabitEthernet0/0
L       201.4.100.62/32 is directly connected, GigabitEthernet0/0
C       201.4.100.64/29 is directly connected, GigabitEthernet0/1
L       201.4.100.70/32 is directly connected, GigabitEthernet0/1

SwitchA

 SwitchA#show run
Building configuration...

Current configuration : 1129 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchA
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 201.4.100.3 255.255.255.240
!
ip default-gateway 201.4.100.2
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

SwitchB

SwitchB#show run
Building configuration...

Current configuration : 1131 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchB
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 201.4.100.19 255.255.255.248
!
ip default-gateway 201.4.100.18
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

SwitchD

    SwitchD#show run
Building configuration...

Current configuration : 1131 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchD
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 201.4.100.35 255.255.255.224
!
ip default-gateway 201.4.100.34
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

SwitchE

    SwitchE#show run
Building configuration...

Current configuration : 1131 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchE
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 201.4.100.67 255.255.255.248
!
ip default-gateway 201.4.100.66
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end
1
  • Please never use screenshots for text. Instead, add the router configurations as text, using the editor's {} preformat option.
    – Zac67
    Dec 23, 2022 at 7:36

2 Answers 2

1

The routers have only routes for their directly connected subnets, nothing else. Without a route to the destination a router simply drops a packet.

Routers learn routes in three ways:

  1. subnets that the router directly connects to are learned automatically
  2. the administrator can manually set up routes to remote subnets
  3. subnet information can be exchanged between routers using routing protocols like OSPF, RIP, IS-IS, ...

You need to set up either static routes for the respective remote networks or a routing protocol between the routers.

0
-1

I think the key of problem is default route in Pc, if you want to go to another gateway you must be set default route directly.

1
  • The PCs' routing looks fine. It's the routers' routing that's off.
    – Zac67
    Dec 23, 2022 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.