0

show ip dhcp pool Mitarbeiter10 gives the following output:

R1#show ip dhcp pool Mitarbeiter10 
Pool Mitarbeiter10 :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0 
Total addresses                : 254
Leased addresses               : 1
Excluded addresses             : 1
Pending event                  : none

1 subnet is currently in the pool
Current index        IP address range                    Leased/Excluded/Total
192.168.10.1         192.168.10.1     - 192.168.10.254    1    / 1     / 254

This refers to the following network

Network

The router interface by which this network can be reached has ip 192.168.10.1. Why is this ip part of the dhcp pool? I know that by default routers will exclude addresses assigned to its interfaces from the dhcp pool. But isn't the current index the ip address which will be assigned to the next client?

Also show run | i excluded-addresses does not list any excluded addresses.

Router configuration:

ip dhcp pool Mitarbeiter10
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 dns-server 209.165.102.6
!
!
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
!
username ISP password 0 Passw0rd
!
!
license udi pid CISCO1941/K9 sn FTX1524OR3V
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.2.1 255.255.255.252
 mtu 1476
 tunnel source Serial0/0/0
 tunnel destination 209.165.101.10
!
!
interface Tunnel6
 no ip address
 mtu 1476
 ipv6 address 2001:DB8:A:1::1/64
 tunnel source Serial0/0/0
 tunnel destination 209.165.101.10
 tunnel mode ipv6ip
!
!
interface GigabitEthernet0/0
 ip address 209.165.102.1 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
 ipv6 address 2001:DB8:A:10::1/64
!
interface Serial0/0/0
 ip address 209.165.101.2 255.255.255.248
 encapsulation ppp
 ppp authentication chap
 ip nat outside
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/1
 network 192.168.10.0 0.0.0.255 area 1
 network 192.168.2.0 0.0.0.255 area 1
!
ip nat inside source list ACL_NAT interface Serial0/0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 
!
ip flow-export version 9
!
ipv6 route 2001:DB8:A:20::/64 2001:DB8:A:1::2
!
ip access-list extended ACL_NAT
 deny ip 192.168.10.0 0.0.0.255 192.168.30.0 0.0.0.255
 permit ip 192.168.10.0 0.0.0.255 any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
1
  • Please edit the question to include the full router configuration. Also, never use an image for text. Simply copy the text and paste it into the question, then use the Preformatted-text option ({}) that is right next to the image option you used.
    – Ron Maupin
    Jan 1, 2023 at 20:53

1 Answer 1

1
ip dhcp pool Mitarbeiter10
 network 192.168.10.0 255.255.255.0

That config adds all legal subnet addresses to the pool. However, the router's own address is implicitly excluded, so it will never be offered to a client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.