0

I have network with switches at access layer and 3 host networks, 2 core routers , 2 border routers , that have iBGP connection with each other and ospf with other 2 core routers, also each of them connected to 2 different ISP’s with eBGP. Border routers get only default routes from ISP’s. I want to split outbound traffic from access layer host networks between 2 ISP’s, for example 2 networks use 1st ISP connection and other 1 network uses 2nd ISP connection. If one connection fails , then all networks that use failed ISP will use another ISP. I want to know how to do it only with BGP , not PBR, ip sla …, only BGP.

BR3:

router ospf 1;
 router-id 10.1.255.2;
 redistribute bgp 200 subnets;
 passive-interface Ethernet0/2;
 default-information originate;
router bgp 200;
 bgp router-id 10.1.255.2;
 bgp log-neighbor-changes;
 network 10.0.0.0 mask 255.255.255.0;
 network 10.0.1.0 mask 255.255.255.0;
 network 10.0.2.0 mask 255.255.255.0;
 neighbor 10.1.255.1 remote-as 200;
 neighbor 10.1.255.1 update-source Loopback0;
 neighbor 10.1.255.1 next-hop-self;
 neighbor 192.168.0.6 remote-as 101;
 maximum-paths 4;

BR4:

router ospf 1;
 router-id 10.1.255.1;
 redistribute bgp 200 subnets;
 passive-interface Ethernet0/1;
 default-information originate;
router bgp 200;
 bgp router-id 10.1.255.1;
 bgp log-neighbor-changes;
 network 10.0.0.0 mask 255.255.255.0;
 network 10.0.1.0 mask 255.255.255.0;
 network 10.0.2.0 mask 255.255.255.0;
 neighbor 10.1.255.2 remote-as 200;
 neighbor 10.1.255.2 update-source Loopback0;
 neighbor 10.1.255.2 next-hop-self;
 neighbor 192.168.0.2 remote-as 100;
 maximum-paths 4;

Network topology

2 Answers 2

3

BGP only deals with destinations and with filling routing tables, BGP doesn't forward packets and BGP doesn't care about source addresses. So requiring 'only BGP' doesn't make much sense.

You seem to want a forwarding engine to make decisions based on the source address of packets, and that's PBR.

2
  • Ok, if it is PBR - how to make flexible solution for what I described? For example if you use next-hop attribute for that - it will not be flexible, because if link between BR3 and BR4 goes down , all load-sharing mechanism will not work.
    – Igor
    Feb 18 at 15:30
  • I don’t know, it’s a setup I would never consider implementing.
    – Teun Vink
    Feb 18 at 20:14
0

You can use ACL to redirect traffic towards those ISPs by connecting those 02 ISP routers or on BR3 and BR4. The problem is you won't have the automatic switching and you will start having asymmetric incoming traffics depending the blocs of IPs you advertise to those ISPs assuming you have public IP of your own. https://community.cisco.com/t5/routing/how-bad-is-asymmetric-routing-in-dual-homed-bgp-please-advise/td-p/752097

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.